aboutsummaryrefslogtreecommitdiff
path: root/security/scamp
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-11-22 00:22:47 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-11-22 00:22:47 +0000
commit115ab4244638b8eb0d3b6f9bf65c56c113df0caa (patch)
tree2ac17e0eaa76e3b3e5727a3090efe2f4e16ba44e /security/scamp
parent5c243d5c84ec8b12e7d7ab7d6a7cefca182f41e6 (diff)
Notes
Diffstat (limited to 'security/scamp')
-rw-r--r--security/scamp/Makefile30
-rw-r--r--security/scamp/distinfo5
-rw-r--r--security/scamp/files/default.sample4
-rw-r--r--security/scamp/files/pkg-message.in38
-rw-r--r--security/scamp/pkg-plist10
5 files changed, 48 insertions, 39 deletions
diff --git a/security/scamp/Makefile b/security/scamp/Makefile
index d309e09de038..8dc32b64a2b9 100644
--- a/security/scamp/Makefile
+++ b/security/scamp/Makefile
@@ -5,44 +5,44 @@
# $FreeBSD$
PORTNAME= scamp
-PORTVERSION= 5.2j
+PORTVERSION= 5.3
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= gerard@seibercom.net
COMMENT= Download & Install additional definition files for Clamav
-RUN_DEPENDS+= bash>=4.1.5_2:${PORTSDIR}/shells/bash \
- clamav>=0.96.1:${PORTSDIR}/security/clamav \
- gnupg>=2.0.14_2:${PORTSDIR}/security/gnupg \
+RUN_DEPENDS= bash>=4.1.9:${PORTSDIR}/shells/bash \
+ clamav>=0.96.4:${PORTSDIR}/security/clamav \
+ gnupg>=2.0.16_2:${PORTSDIR}/security/gnupg \
rsync>=3.0.7:${PORTSDIR}/net/rsync
+LICENSE= BSD
+
.if exists (${LOCALBASE}/bin/wget) && ! exists (${LOCALBASE}/bin/curl)
-RUN_DEPENDS+= wget>=1.12:${PORTSDIR}/ftp/wget
+RUN_DEPENDS+= wget>=1.12_2:${PORTSDIR}/ftp/wget
.else
-RUN_DEPENDS+= curl>=7.20.1:${PORTSDIR}/ftp/curl
+RUN_DEPENDS+= curl>=7.21.1:${PORTSDIR}/ftp/curl
.endif
NO_BUILD= yes
-
SUB_FILES= pkg-message
MAN1= scamp.1
-MANCOMPRESSED= no
post-patch:
@${REINPLACE_CMD} -e 's|CLAMAV_DB=$${CLAMAV_DB:-""}|CLAMAV_DB=$${CLAMAV_DB:-\"/var/db/clamav\"}|g' ${WRKSRC}/${PORTNAME}.sh
- @${REINPLACE_CMD} -e 's|CONFIG_DIR=$${CONFIG_DIR:-"/etc/scamp"}|CONFIG_DIR=$${CONFIG_DIR:-\"${PREFIX}/etc/scamp\"}|g' ${WRKSRC}/${PORTNAME}.sh
+ @${REINPLACE_CMD} -e 's|CONFIG_DIR=$${CONFIG_DIR:-"/etc/scamp"}|CONFIG_DIR=$${CONFIG_DIR:-"${ETCDIR}"}|g' ${WRKSRC}/${PORTNAME}.sh
post-install:
- @if [ ! -d ${PREFIX}/etc/scamp ]; then \
- ${MKDIR} ${PREFIX}/etc/scamp ; \
+ @if [ ! -d ${ETCDIR} ]; then \
+ ${MKDIR} ${ETCDIR} ; \
fi
- @${INSTALL_DATA} ${FILESDIR}/default.sample ${PREFIX}/etc/scamp/
- @if [ ! -f ${PREFIX}/etc/scamp/default ]; then \
- ${CP} -p ${PREFIX}/etc/scamp/default.sample \
- ${PREFIX}/etc/scamp/default ; \
+ @${INSTALL_DATA} ${FILESDIR}/default.sample ${ETCDIR}
+ @if [ ! -f ${ETCDIR}/default ]; then \
+ ${CP} -p ${ETCDIR}/default.sample \
+ ${ETCDIR}/default ; \
fi
do-install:
diff --git a/security/scamp/distinfo b/security/scamp/distinfo
index 047f11695f56..bf14800e54d5 100644
--- a/security/scamp/distinfo
+++ b/security/scamp/distinfo
@@ -1,3 +1,2 @@
-MD5 (scamp-5.2j.tar.gz) = e987825d06849c40370a32d2b063a68d
-SHA256 (scamp-5.2j.tar.gz) = 042e10f426df3d9967c395279b331fafa57a77626d9ad082495716c1c425299a
-SIZE (scamp-5.2j.tar.gz) = 24827
+SHA256 (scamp-5.3.tar.gz) = b622b3be38d76d656134e134c6c929c1b7b184fb36a3d66e016371b683fd5a05
+SIZE (scamp-5.3.tar.gz) = 28949
diff --git a/security/scamp/files/default.sample b/security/scamp/files/default.sample
index 248e1e6729bf..bed1a4f23075 100644
--- a/security/scamp/files/default.sample
+++ b/security/scamp/files/default.sample
@@ -1,7 +1,7 @@
# This is the /usr/local/etc/scamp/default file.
-# Created June 10, 2010 @ 15:37:48
+# Created November 14, 2010 @ 07:09:46
-SCAMP_VERSION=5.2j
+SCAMP_VERSION=5.3
CLAMAV_DB=/var/db/clamav
T_DIR=/var/db/clamav/tmp
C_GROUP=clamav
diff --git a/security/scamp/files/pkg-message.in b/security/scamp/files/pkg-message.in
index 053afb397184..3e3fb360338f 100644
--- a/security/scamp/files/pkg-message.in
+++ b/security/scamp/files/pkg-message.in
@@ -1,15 +1,25 @@
-***********************************************************************
- ** WARNING ** *
- *
-* Please read the README file before running "scamp.sh" *
-* If updating from an earlier version, it is suggested *
-* that you first run: *
-* *
-* "scamp.sh -D" to delete all old configuration. Then, running *
-* "scamp.sh" will cause the script to create a new configuration *
-* *
-* You will need to manually create any additional configuration files.*
-* Read the README or type "man scamp" for further assistance. *
-* *
-***********************************************************************
+************************************************************************
+* ** WARNING ** *
+* *
+* Please read the README file before running "scamp.sh" *
+* If updating from a version earlier than 5.2j, it is suggested *
+* that you first run: "scamp.sh -D" to delete all old configurations. *
+* Then, running "scamp.sh" will cause the script to create a new *
+* configuration file. *
+* *
+* Check the "README" or "man scamp" for further information. *
+* *
+* The new versions of "scamp" can download definition files not *
+* previously available in the older versions. *
+* *
+* You will also have to recreate any other additional configuration *
+* files you might have used previously. *
+* *
+* I apologize for this inconvenience; however, it is the only feasible *
+* way to insure that you have the most up-to-date configuration. *
+* *
+* You will need to manually create any additional configuration files. *
+* Read the README or type "man scamp" for further assistance. *
+* *
+************************************************************************
diff --git a/security/scamp/pkg-plist b/security/scamp/pkg-plist
index a2101eeaaac4..40f98c4d856b 100644
--- a/security/scamp/pkg-plist
+++ b/security/scamp/pkg-plist
@@ -4,8 +4,8 @@ bin/scamp.sh
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/Release.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec if cmp -s %D/etc/scamp/default.sample %D/etc/scamp/default; then rm -f %D/etc/scamp/default; fi
-etc/scamp/default.sample
-@exec if [ ! -f %D/etc/scamp/default ] ; then cp -p %D/%F %B/default; fi
-@exec mkdir -p %D/etc/scamp
-@dirrmtry etc/scamp
+@unexec if cmp -s %D/%%ETCDIR%%/default.sample %D/%%ETCDIR%%/default; then rm -f %D/%%ETCDIR%%/default; fi
+%%ETCDIR%%/default.sample
+@exec if [ ! -f %D/%%ETCDIR%%/default ] ; then cp -p %D/%F %B/default; fi
+@exec mkdir -p %D/%%ETCDIR%%
+@dirrmtry %%ETCDIR%%