aboutsummaryrefslogtreecommitdiff
path: root/security/scamp
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2013-04-27 20:00:41 +0000
committerStefan Walter <stefan@FreeBSD.org>2013-04-27 20:00:41 +0000
commitb2de0e287a0d761c88aede684150891ec35849ab (patch)
tree17c473f3a34f6f3f42897cc49591e419676676a6 /security/scamp
parentaa1a91bb34207eaa4e49e695c46383244c1026fe (diff)
downloadports-b2de0e287a0d761c88aede684150891ec35849ab.tar.gz
ports-b2de0e287a0d761c88aede684150891ec35849ab.zip
Notes
Diffstat (limited to 'security/scamp')
-rw-r--r--security/scamp/Makefile33
-rw-r--r--security/scamp/distinfo4
-rw-r--r--security/scamp/files/default.sample20
-rw-r--r--security/scamp/pkg-descr1
-rw-r--r--security/scamp/pkg-plist11
5 files changed, 31 insertions, 38 deletions
diff --git a/security/scamp/Makefile b/security/scamp/Makefile
index 9e20201723d7..ccdb82c9bb9a 100644
--- a/security/scamp/Makefile
+++ b/security/scamp/Makefile
@@ -1,11 +1,8 @@
-# New ports collection makefile for: scamp
-# Date created: 31 March 2009
-# Whom: Gerard Seibert <gerard@seibercom.net>
-#
+# Created by: Gerard Seibert <gerard@seibercom.net>
# $FreeBSD$
PORTNAME= scamp
-PORTVERSION= 5.3b
+PORTVERSION= 5.4
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -14,15 +11,15 @@ COMMENT= Download & Install additional definition files for Clamav
LICENSE= BSD
-RUN_DEPENDS= bash>=4.2.20:${PORTSDIR}/shells/bash \
- clamav>=0.97.3_1:${PORTSDIR}/security/clamav \
- gnupg>=2.0.18_1:${PORTSDIR}/security/gnupg \
+RUN_DEPENDS= bash>=4.2.42:${PORTSDIR}/shells/bash \
+ clamav>=0.97.7:${PORTSDIR}/security/clamav \
+ gnupg>=2.0.19:${PORTSDIR}/security/gnupg \
rsync>=3.0.9:${PORTSDIR}/net/rsync
.if exists (${LOCALBASE}/bin/wget) && ! exists (${LOCALBASE}/bin/curl)
-RUN_DEPENDS+= wget>=1.13.4_1:${PORTSDIR}/ftp/wget
+RUN_DEPENDS+= wget>=1.14:${PORTSDIR}/ftp/wget
.else
-RUN_DEPENDS+= curl>=7.21.3_2:${PORTSDIR}/ftp/curl
+RUN_DEPENDS+= curl>=7.24.0_2:${PORTSDIR}/ftp/curl
.endif
NO_BUILD= yes
@@ -30,6 +27,8 @@ SUB_FILES= pkg-message
MAN1= scamp.1
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|CLAMAV_DB=$${CLAMAV_DB:-""}|CLAMAV_DB=$${CLAMAV_DB:-\"/var/db/clamav\"}|g' ${WRKSRC}/${PORTNAME}.sh
@${REINPLACE_CMD} -e 's|CONFIG_DIR=$${CONFIG_DIR:-"/etc/scamp"}|CONFIG_DIR=$${CONFIG_DIR:-"${ETCDIR}"}|g' ${WRKSRC}/${PORTNAME}.sh
@@ -40,19 +39,21 @@ post-install:
fi
@${INSTALL_DATA} ${FILESDIR}/default.sample ${ETCDIR}
- @if [ ! -f ${ETCDIR}/default ]; then \
- ${CP} -p ${ETCDIR}/default.sample \
- ${ETCDIR}/default ; \
- fi
+
+ @if [ ! -f ${PREFIX}/etc/scamp/default ]; then \
+ ${CP} -p ${PREFIX}/etc/scamp/default.sample ${PREFIX}/etc/scamp/default ; \
+ fi
do-install:
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTNAME}.sh ${PREFIX}/bin
cd ${WRKSRC} && ${INSTALL_MAN} scamp.1 ${MANPREFIX}/man/man1
-.ifndef(NOPORTDOCS)
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README CHANGE.LOG INSTALL Release.html ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README CHANGE.LOG INSTALL Release.pdf ${DOCSDIR}
.endif
+
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/security/scamp/distinfo b/security/scamp/distinfo
index fb0450150f58..451c3186a459 100644
--- a/security/scamp/distinfo
+++ b/security/scamp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scamp-5.3b.tar.gz) = ad557fbad486d8baba6d1f55e6492af555adb00830cca4ff904c0fb34659d5c5
-SIZE (scamp-5.3b.tar.gz) = 40988
+SHA256 (scamp-5.4.tar.gz) = 8e0273e6f0e6f3c8d05f5fe194459e3dc606ec7daca4094527b9f71892e9e3c6
+SIZE (scamp-5.4.tar.gz) = 134541
diff --git a/security/scamp/files/default.sample b/security/scamp/files/default.sample
index 2aa32e0e7c5d..0e0333135539 100644
--- a/security/scamp/files/default.sample
+++ b/security/scamp/files/default.sample
@@ -1,34 +1,28 @@
# This is the /usr/local/etc/scamp/default file.
-# Created February 21, 2012
+# Created March 25, 2013
-SCAMP_VERSION=5.3b
-CLAMAV_DB=/var/db/clamav
-T_DIR=/var/db/clamav/tmp
C_GROUP=clamav
C_PID=/var/run/clamav/clamd.pid
C_USER=clamav
+CLAMAV_DB=/var/db/clamav
GET_LDB=1
GET_MALWARE=1
-GET_MSRBL=0
GET_SANE=1
GET_SECURITE=4
GET_WINNOW=1
gpg_key_url=http://www.sanesecurity.net/publickey.gpg
L_TYPE=1
MK_LOG=0
-MSRBL=rsync://rsync.mirror.msrbl.com/msrbl/
-msrbl_Images=MSRBL-Images.hdb
-msrbl_SPAM=MSRBL-SPAM.ndb
-msrbl_SPAM_CR=MSRBL-SPAM-CR.ndb
-MSR_DIR=/var/db/clamav/tmp/msr
MW_DIR=/var/db/clamav/tmp/malware
MW_FILE=mbl.ndb
MW_URL=http://www.malwarepatrol.com.br/cgi/submit?action=list_clamav_ext
RELOAD=1
-REST=1
-SANE=rsync://rsync.sanesecurity.net/sanesecurity
+REST=0
SANE_DB=/var/db/clamav/tmp/sane
+SANE=rsync://rsync.sanesecurity.net/sanesecurity
+SCAMP_VERSION=5.4
SI_DIR=/var/db/clamav/tmp/securite
SYS_LOG=1
-WPC=1
+T_DIR=/var/db/clamav/tmp
W_SUM=1
+WPC=1
diff --git a/security/scamp/pkg-descr b/security/scamp/pkg-descr
index 8c155a4e4d77..5c442a5da4ef 100644
--- a/security/scamp/pkg-descr
+++ b/security/scamp/pkg-descr
@@ -3,7 +3,6 @@ following sites:
sanesecurity.com
malware.com.br
-msrbl.com
clamav.securiteinfo.com
Site Address:
diff --git a/security/scamp/pkg-plist b/security/scamp/pkg-plist
index 40f98c4d856b..adcf9dd33b55 100644
--- a/security/scamp/pkg-plist
+++ b/security/scamp/pkg-plist
@@ -2,10 +2,9 @@ bin/scamp.sh
%%PORTDOCS%%%%DOCSDIR%%/CHANGE.LOG
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/Release.html
+%%PORTDOCS%%%%DOCSDIR%%/Release.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec if cmp -s %D/%%ETCDIR%%/default.sample %D/%%ETCDIR%%/default; then rm -f %D/%%ETCDIR%%/default; fi
-%%ETCDIR%%/default.sample
-@exec if [ ! -f %D/%%ETCDIR%%/default ] ; then cp -p %D/%F %B/default; fi
-@exec mkdir -p %D/%%ETCDIR%%
-@dirrmtry %%ETCDIR%%
+@exec mkdir -p %D/etc/scamp
+etc/scamp/default.sample
+@exec if [ ! -f %D/etc/scamp/default ] ; then cp -p %D/%F %B/default; fi
+@dirrmtry etc/scamp