aboutsummaryrefslogtreecommitdiff
path: root/security/scanssh
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-04-23 22:57:04 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-04-23 22:57:04 +0000
commitcb9984c3da24fb5539d6a4ef4f1f2b62121227aa (patch)
tree0d0029e4c2469c36b357a1ee79a2192a6e6c8278 /security/scanssh
parent630ec3736032facb44b1aba8379bbec4a63aea14 (diff)
downloadports-cb9984c3da24fb5539d6a4ef4f1f2b62121227aa.tar.gz
ports-cb9984c3da24fb5539d6a4ef4f1f2b62121227aa.zip
Notes
Diffstat (limited to 'security/scanssh')
-rw-r--r--security/scanssh/Makefile13
-rw-r--r--security/scanssh/distinfo4
-rw-r--r--security/scanssh/files/patch-Makefile.in11
-rw-r--r--security/scanssh/files/patch-aa10
-rw-r--r--security/scanssh/files/patch-ab10
-rw-r--r--security/scanssh/files/patch-pcapu.c16
-rw-r--r--security/scanssh/pkg-descr7
-rw-r--r--security/scanssh/pkg-plist3
8 files changed, 25 insertions, 49 deletions
diff --git a/security/scanssh/Makefile b/security/scanssh/Makefile
index 2bfa0e530cac..9b009c4bc35d 100644
--- a/security/scanssh/Makefile
+++ b/security/scanssh/Makefile
@@ -6,24 +6,23 @@
#
PORTNAME= scanssh
-PORTVERSION= 1.60b
-PORTREVISION= 1
+PORTVERSION= 2.1
CATEGORIES= security net
MASTER_SITES= http://www.monkey.org/~provos/
-DISTNAME= ${PORTNAME}-1.6b
MAINTAINER= kris@FreeBSD.org
-COMMENT= Scanssh scans a subnet and reports the version of SSH installed
+COMMENT= Scans networks for open proxies, SSH, Web and SMTP servers
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
+ ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= YES
+PLIST_FILES= bin/scanssh
MAN1= scanssh.1
-WRKSRC= ${WRKDIR}/scanssh
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/scanssh ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/scanssh.1 ${PREFIX}/man/man1
- ${MKDIR} ${PREFIX}/share/scanssh/
- ${TOUCH} ${PREFIX}/share/scanssh/exclude.list
.include <bsd.port.mk>
diff --git a/security/scanssh/distinfo b/security/scanssh/distinfo
index 333f5811d35f..99dcab4b18d5 100644
--- a/security/scanssh/distinfo
+++ b/security/scanssh/distinfo
@@ -1,2 +1,2 @@
-MD5 (scanssh-1.6b.tar.gz) = b0b7a4e6953a878b188156449ae0750f
-SIZE (scanssh-1.6b.tar.gz) = 51064
+MD5 (scanssh-2.1.tar.gz) = 9fab4253b56b2d15367d4872b370cdcb
+SIZE (scanssh-2.1.tar.gz) = 111481
diff --git a/security/scanssh/files/patch-Makefile.in b/security/scanssh/files/patch-Makefile.in
new file mode 100644
index 000000000000..a6e23615904e
--- /dev/null
+++ b/security/scanssh/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Apr 23 15:51:17 2005
++++ Makefile.in Sat Apr 23 15:51:24 2005
+@@ -79,7 +79,7 @@
+ scanssh_SOURCES = scanssh.c atomicio.c exclude.c connecter.c xmalloc.c interface.c socks.c http.c telnet.c exclude.h interface.h scanssh.h socks.h xmalloc.h
+
+ scanssh_LDADD = @LIBOBJS@ @PCAPLIB@ @EVENTLIB@ @DNETLIB@
+-CFLAGS = -O2 -Wall -g
++CFLAGS+= -Wall -g
+
+ INCLUDES = -I$(top_srcdir)/@DNETCOMPAT@ -I$(top_srcdir)/compat @EVENTINC@ @PCAPINC@ @DNETINC@
+
diff --git a/security/scanssh/files/patch-aa b/security/scanssh/files/patch-aa
deleted file mode 100644
index a55565066b0b..000000000000
--- a/security/scanssh/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- exclude.c.orig Fri Sep 8 02:53:19 2000
-+++ exclude.c Fri Sep 8 02:53:34 2000
-@@ -40,7 +40,7 @@
-
- #include "exclude.h"
-
--char *excludefile = "exclude.list";
-+char *excludefile = PREFIX "/share/scanssh/exclude.list";
- struct exclude_list excludequeue;
- struct exclude_list rndexclqueue;
diff --git a/security/scanssh/files/patch-ab b/security/scanssh/files/patch-ab
deleted file mode 100644
index c3a71a9d1cde..000000000000
--- a/security/scanssh/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.in.orig Fri Mar 9 19:07:36 2001
-+++ Makefile.in Fri Mar 9 19:07:57 2001
-@@ -6,7 +6,7 @@
- VPATH= @srcdir@
-
- CC= @CC@
--CFLAGS= @CFLAGS@ @DEFS@ -I. -I$(srcdir) -I$(srcdir)/missing @PCAPINC@ -D_BSD_SOURCE
-+CFLAGS= @CFLAGS@ @DEFS@ -I. -I$(srcdir) -I$(srcdir)/missing @PCAPINC@ -D_BSD_SOURCE -DPREFIX=\"@prefix@\"
- LDFLAGS= @LDFLAGS@
- LIBS= @LIBS@ @PCAPLIB@
diff --git a/security/scanssh/files/patch-pcapu.c b/security/scanssh/files/patch-pcapu.c
deleted file mode 100644
index 2d2de113dc46..000000000000
--- a/security/scanssh/files/patch-pcapu.c
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- pcapu.c.orig Mon Mar 3 17:55:38 2003
-+++ pcapu.c Mon Mar 3 17:56:03 2003
-@@ -47,8 +47,8 @@
- #include "config.h"
-
- struct phdr {
-- unsigned long saddr;
-- unsigned long daddr;
-+ in_addr_t saddr;
-+ in_addr_t daddr;
- char zero;
- unsigned char protocol;
- unsigned short length;
diff --git a/security/scanssh/pkg-descr b/security/scanssh/pkg-descr
index a32ff11ce444..fbf559fb454b 100644
--- a/security/scanssh/pkg-descr
+++ b/security/scanssh/pkg-descr
@@ -1,3 +1,8 @@
-Scanssh scans a subnet and reports the version of SSH installed.
+ScanSSH supports scanning a list of addresses and networks for open proxies,
+SSH protocol servers, Web and SMTP servers. Where possible ScanSSH, displays
+the version number of the running services. ScanSSH protocol scanner supports
+random selection of IP addresses from large network ranges and is useful for
+gathering statistics on the deployment of SSH protocol servers in a company
+or the Internet as whole.
WWW: http://www.monkey.org/~provos/
diff --git a/security/scanssh/pkg-plist b/security/scanssh/pkg-plist
deleted file mode 100644
index 143b511fac96..000000000000
--- a/security/scanssh/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/scanssh
-share/scanssh/exclude.list
-@dirrm share/scanssh