aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse-plugins
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /security/seahorse-plugins
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Notes
Diffstat (limited to 'security/seahorse-plugins')
-rw-r--r--security/seahorse-plugins/Makefile6
-rw-r--r--security/seahorse-plugins/files/patch-libseahorse_seahorse-notification.c11
2 files changed, 14 insertions, 3 deletions
diff --git a/security/seahorse-plugins/Makefile b/security/seahorse-plugins/Makefile
index bad3af7cb24a..6b3d5a1f59cf 100644
--- a/security/seahorse-plugins/Makefile
+++ b/security/seahorse-plugins/Makefile
@@ -3,12 +3,12 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse-plugins/Makefile,v 1.25 2010/04/27 22:22:07 kwm Exp $
+# $MCom: ports/security/seahorse-plugins/Makefile,v 1.28 2011/07/03 11:57:45 kwm Exp $
#
PORTNAME= seahorse-plugins
PORTVERSION= 2.30.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -83,7 +83,7 @@ PLIST_SUB+= APPLET="@comment "
.endif
.if !defined(WITHOUT_NOTIFY)
-LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+=--disable-libnotify
.endif
diff --git a/security/seahorse-plugins/files/patch-libseahorse_seahorse-notification.c b/security/seahorse-plugins/files/patch-libseahorse_seahorse-notification.c
new file mode 100644
index 000000000000..7ddf0bb3fe00
--- /dev/null
+++ b/security/seahorse-plugins/files/patch-libseahorse_seahorse-notification.c
@@ -0,0 +1,11 @@
+--- libseahorse/seahorse-notification.c.orig 2011-03-07 09:25:10.000000000 +0100
++++ libseahorse/seahorse-notification.c 2011-03-07 09:25:57.000000000 +0100
+@@ -213,7 +213,7 @@
+ heading = format_key_text (snotif->heading);
+ message = format_key_text (snotif->message);
+
+- notif = notify_notification_new (heading, message, snotif->icon, attachto);
++ notif = notify_notification_new (heading, message, snotif->icon);
+
+ g_free (heading);
+ g_free (message);