aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-22 00:06:01 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-22 00:06:01 +0000
commit4b6647a9a73a604bb629522bfe4e207b897d6853 (patch)
tree46d77b02f1122c75d0c8187ac878e9e53e16d463 /security/seahorse/Makefile
parent2530951c6bdb25bb66335bf1ddf900a1c2d37199 (diff)
downloadports-4b6647a9a73a604bb629522bfe4e207b897d6853.tar.gz
ports-4b6647a9a73a604bb629522bfe4e207b897d6853.zip
Notes
Diffstat (limited to 'security/seahorse/Makefile')
-rw-r--r--security/seahorse/Makefile33
1 files changed, 21 insertions, 12 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 4b34da640056..055c1835a328 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= seahorse
-PORTVERSION= 0.7.3
-PORTREVISION= 4
+PORTVERSION= 0.7.5
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR=sources/${PORTNAME}/0.7
@@ -18,21 +17,31 @@ COMMENT= A front end for GnuPG
BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= gpgme03.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS= gpgme.14:${PORTSDIR}/security/gpgme
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix eel2
-USE_INC_LIBTOOL_VER=13
+USE_GNOME= gnomehack intlhack gnomeprefix eel2
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
+INSTALLS_OMF= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g; \
- s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
- @${CP} ${WRKSRC}/data/seahorse.schemas.in ${WRKSRC}/data/seahorse.schemas
+GCONF_SCHEMAS= seahorse.schemas
-.include <bsd.port.mk>
+OPTIONS= GEDIT "Enable the gedit plug-in" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GEDIT)
+BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit2
+RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit2
+PLIST_SUB+= GEDIT=""
+.else
+PLIST_SUB+= GEDIT="@comment "
+CONFIGURE_ARGS+=--disable-gedit
+.endif
+
+.include <bsd.port.post.mk>