aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /security/seahorse
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Notes
Diffstat (limited to 'security/seahorse')
-rw-r--r--security/seahorse/Makefile8
-rw-r--r--security/seahorse/pkg-plist26
2 files changed, 31 insertions, 3 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 3819c0ea8041..ce0e158e664b 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -3,7 +3,7 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.16 2006/03/05 21:52:25 marcus Exp $
+# $MCom: ports/security/seahorse/Makefile,v 1.18 2006/10/01 01:56:57 ahze Exp $
#
PORTNAME= seahorse
@@ -21,6 +21,7 @@ BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= ${BUILD_DEPENDS}
LIB_DEPENDS= gpgme.17:${PORTSDIR}/security/gpgme
+USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_X_PREFIX= yes
@@ -28,7 +29,6 @@ USE_GMAKE= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
-INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-gpg-check
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -37,11 +37,13 @@ GCONF_SCHEMAS= seahorse.schemas
OPTIONS= NAUTILUS "Enable the Nautilus component" on \
LDAP "Enable LDAP support" on \
- GEDIT "Enable GEdit plug-in support" on \
HKP "Enable HKP keyserver interface" on
+# GEDIT "Enable GEdit plug-in support" on
.include <bsd.port.pre.mk>
+# Gedit not working right now..
+WITHOUT_GEDIT= yes
.if !defined(WITHOUT_GEDIT)
BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
diff --git a/security/seahorse/pkg-plist b/security/seahorse/pkg-plist
index 5b17b6dc13fe..363cf20d0408 100644
--- a/security/seahorse/pkg-plist
+++ b/security/seahorse/pkg-plist
@@ -112,3 +112,29 @@ share/locale/zh_TW/LC_MESSAGES/seahorse.mo
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/ne/LC_MESSAGES
+@dirrmtry share/locale/ne
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca