aboutsummaryrefslogtreecommitdiff
path: root/security/seccure
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-08-20 08:02:30 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-08-20 08:02:30 +0000
commit6894743b405312625c5de0c0dfdcd579f2f6ca11 (patch)
treeadf6a14f0f20c3377e00a8273258faf1c861c3b6 /security/seccure
parent41c21bb925b325ae4636921b19bad37aa41deaad (diff)
Notes
Diffstat (limited to 'security/seccure')
-rw-r--r--security/seccure/Makefile6
-rw-r--r--security/seccure/distinfo4
-rw-r--r--security/seccure/files/patch-Makefile2
3 files changed, 7 insertions, 5 deletions
diff --git a/security/seccure/Makefile b/security/seccure/Makefile
index bc2be51af4a2..89900040152e 100644
--- a/security/seccure/Makefile
+++ b/security/seccure/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= seccure
-PORTVERSION= 0.4
-PORTREVISION= 4
+PORTVERSION= 0.5
CATEGORIES= security
MASTER_SITES= http://point-at-infinity.org/seccure/ \
${MASTER_SITE_NETBSD}
@@ -11,6 +10,9 @@ MASTER_SITES= http://point-at-infinity.org/seccure/ \
MAINTAINER= zi@FreeBSD.org
COMMENT= Elliptic Curve Crypto Utility for Reliable Encryption
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
USE_GCC= any
diff --git a/security/seccure/distinfo b/security/seccure/distinfo
index e266381e9797..8a4b4eeb707d 100644
--- a/security/seccure/distinfo
+++ b/security/seccure/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seccure-0.4.tar.gz) = 33d690a7034ee349bce4911a8b7c73e6e3cd13a140f429e9e628d5cd5a3bb955
-SIZE (seccure-0.4.tar.gz) = 31881
+SHA256 (seccure-0.5.tar.gz) = 6566ce4afea095f83690b93078b910ca5b57b581ebc60e722f6e3fe8e098965b
+SIZE (seccure-0.5.tar.gz) = 32171
diff --git a/security/seccure/files/patch-Makefile b/security/seccure/files/patch-Makefile
index 9cb531e423c3..fbc5a21b14c7 100644
--- a/security/seccure/files/patch-Makefile
+++ b/security/seccure/files/patch-Makefile
@@ -2,7 +2,7 @@
+++ /tmp/Makefile 2011-05-26 19:30:35.000000000 -0400
@@ -1,4 +1,6 @@
-CFLAGS = -O2 -Wall # -D NOBEEP
-+CFLAGS = -L$(LOCALBASE)/lib -I$(LOCALBASE)/include -O2 -DNOBEEP -DNOMEMLOCK
++CFLAGS = -L$(LOCALBASE)/lib -I$(LOCALBASE)/include -O2 -DNOBEEP -DNOMEMLOCK -lgcrypt
+
+all: default