aboutsummaryrefslogtreecommitdiff
path: root/security/secpanel/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-12-12 01:28:04 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-12-12 01:28:04 +0000
commit1f457abfd193212bdbfa5462afb0a577c66282cf (patch)
treec8f85ebc2bde3d25f12f4ce12565a403f360b26d /security/secpanel/Makefile
parent0cc6a79233d0ba2d3617f965a12a125a234cc81e (diff)
downloadports-1f457abfd193212bdbfa5462afb0a577c66282cf.tar.gz
ports-1f457abfd193212bdbfa5462afb0a577c66282cf.zip
Notes
Diffstat (limited to 'security/secpanel/Makefile')
-rw-r--r--security/secpanel/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index 2a5afc4221b1..2cff3fce5cba 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= secpanel
-PORTVERSION= 0.5.2
+PORTVERSION= 0.5.3
PORTEPOCH= 1
CATEGORIES= security tcl84 tk84
MASTER_SITES= http://themediahost.de/secpanel/data/ CENKES
+EXTRACT_SUFX= .tgz
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= GUI for managing and running ssh and related utilities
@@ -20,16 +21,18 @@ USE_TK_RUN= 84
NO_BUILD= yes
post-extract:
+ @${MV} ${WRKDIR}/usr ${WRKSRC}
@${CHMOD} -R a+rX ${WRKSRC}/
+ @${RM} -rf ${WRKSRC}/local/lib/secpanel/out/
post-patch:
@${REINPLACE_CMD} -e 's!^exec wish!exec ${WISH}!' \
-e 's!\[file dirname \[info script\]\]/../lib/secpanel!${DATADIR}!' \
-e 's!askpassbin askpass!askpassbin ssh-askpass!' \
- ${WRKSRC}/src/bin/secpanel
+ ${WRKSRC}/local/bin/secpanel
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/src/bin/secpanel ${PREFIX}/bin/
- @cd ${WRKSRC}/src/lib/secpanel/&&${COPYTREE_SHARE} . ${DATADIR}/
+ @${INSTALL_SCRIPT} ${WRKSRC}/local/bin/secpanel ${PREFIX}/bin/
+ @cd ${WRKSRC}/local/lib/secpanel/&&${COPYTREE_SHARE} . ${DATADIR}/
.include <bsd.port.mk>