aboutsummaryrefslogtreecommitdiff
path: root/security/secpanel
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-26 03:28:12 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-26 03:28:12 +0000
commit07f073e51708916ee9c177b3daee39b0226da95a (patch)
tree91ec21eac23bc1b317ce3a4aa26d3ceec7670229 /security/secpanel
parent09d91258bb2de96c6c82f905fa290f86fc53ba00 (diff)
downloadports-07f073e51708916ee9c177b3daee39b0226da95a.tar.gz
ports-07f073e51708916ee9c177b3daee39b0226da95a.zip
Notes
Diffstat (limited to 'security/secpanel')
-rw-r--r--security/secpanel/Makefile39
-rw-r--r--security/secpanel/distinfo1
-rw-r--r--security/secpanel/pkg-comment1
-rw-r--r--security/secpanel/pkg-descr10
-rw-r--r--security/secpanel/pkg-plist12
5 files changed, 63 insertions, 0 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
new file mode 100644
index 000000000000..972c30974e44
--- /dev/null
+++ b/security/secpanel/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: secpanel
+# Date created: 11 June 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= secpanel
+PORTVERSION= 0.31
+CATEGORIES= security
+MASTER_SITES= http://www2.wiwi.uni-marburg.de/~leich/soft/secpanel/
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83 \
+ ssh-askpass:${PORTSDIR}/security/openssh-askpass
+
+USE_X_PREFIX= yes
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e 's!^exec wish!exec wish8.3!; \
+ s!\[file dirname \[info script\]\]/../lib/secpanel!${PREFIX}/share/secpanel! ; \
+ s!askpassbin askpass!askpassbin ssh-askpass!' ${WRKSRC}/src/bin/secpanel
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/bin/secpanel ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/secpanel
+.for file in gui.tcl listserver.tcl secpanel.dist secpanel.wait
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/lib/secpanel/${file} ${PREFIX}/share/secpanel
+.endfor
+ @${MKDIR} ${PREFIX}/share/secpanel/images
+.for file in configs.gif connects.gif keys.gif profiles.gif scp.gif
+ ${INSTALL_DATA} ${WRKSRC}/src/lib/secpanel/images/${file} \
+ ${PREFIX}/share/secpanel/images
+.endfor
+
+.include <bsd.port.mk>
diff --git a/security/secpanel/distinfo b/security/secpanel/distinfo
new file mode 100644
index 000000000000..c05020287948
--- /dev/null
+++ b/security/secpanel/distinfo
@@ -0,0 +1 @@
+MD5 (secpanel-0.31.tar.gz) = 1094c655bf780fe28e4ddccf1aefb72e
diff --git a/security/secpanel/pkg-comment b/security/secpanel/pkg-comment
new file mode 100644
index 000000000000..b2751f466b64
--- /dev/null
+++ b/security/secpanel/pkg-comment
@@ -0,0 +1 @@
+GUI for managing and running ssh and related utilities
diff --git a/security/secpanel/pkg-descr b/security/secpanel/pkg-descr
new file mode 100644
index 000000000000..68cdfba5c875
--- /dev/null
+++ b/security/secpanel/pkg-descr
@@ -0,0 +1,10 @@
+SecPanel serves as a GUI for managing and running SSH (Secure Shell)
+and SCP (Secure Copy) connections. Nearly all connection-parameters
+are adjusted by one mouseclick (compression, port-forwarding, etc.).
+It also manages the SSH-agent. SecPanel works with ssh 1.2.x and
+OpenSSH.
+
+WWW: http://www2.wiwi.uni-marburg.de/~leich/soft/secpanel/
+
+- Pete
+petef@databits.net
diff --git a/security/secpanel/pkg-plist b/security/secpanel/pkg-plist
new file mode 100644
index 000000000000..76a715490f87
--- /dev/null
+++ b/security/secpanel/pkg-plist
@@ -0,0 +1,12 @@
+bin/secpanel
+share/secpanel/gui.tcl
+share/secpanel/listserver.tcl
+share/secpanel/secpanel.dist
+share/secpanel/secpanel.wait
+share/secpanel/images/configs.gif
+share/secpanel/images/connects.gif
+share/secpanel/images/keys.gif
+share/secpanel/images/profiles.gif
+share/secpanel/images/scp.gif
+@dirrm share/secpanel/images
+@dirrm share/secpanel