aboutsummaryrefslogtreecommitdiff
path: root/security/sfs/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-01-02 05:23:45 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-01-02 05:23:45 +0000
commit221b756b88810bd343882fc1a42cbd0a5d726f20 (patch)
tree187f1fff9f16fe033d38b6f5ecaa45107c7390a1 /security/sfs/Makefile
parentbb284b0353fd454ecd7bccf361511ed5a5ed4ee0 (diff)
downloadports-221b756b88810bd343882fc1a42cbd0a5d726f20.tar.gz
ports-221b756b88810bd343882fc1a42cbd0a5d726f20.zip
Notes
Diffstat (limited to 'security/sfs/Makefile')
-rw-r--r--security/sfs/Makefile34
1 files changed, 22 insertions, 12 deletions
diff --git a/security/sfs/Makefile b/security/sfs/Makefile
index 5172fa9e9044..23d45d7736db 100644
--- a/security/sfs/Makefile
+++ b/security/sfs/Makefile
@@ -7,27 +7,25 @@
#
PORTNAME= sfs
-PORTVERSION= 0.6
-PORTREVISION= 2
+PORTVERSION= 0.7.2
CATEGORIES= security net
-MASTER_SITES= http://www.fs.net/sfs/new-york.lcs.mit.edu:85xq6pznt4mgfvj4mb23x6b8adak55ue/pub/sfswww/dist/
+MASTER_SITES= http://www.fs.net/sfs/@new-york.lcs.mit.edu,u83s4uk49nt8rmp4uwmt2exvz6d3cavh/pub/sfswww/dist/
MAINTAINER= handler@grendel.net
-.include <bsd.port.pre.mk>
+PLIST_SUB= SFS_VERSION=${PORTVERSION}
USE_GMAKE= yes
-USE_OPENSSL= yes
-USE_BISON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-sfsuser=sfs \
--with-sfsgroup=sfs \
--with-sfsdir=/var/spool/sfs \
--with-etcdir=${PREFIX}/etc/sfs \
- --with-openssl=${OPENSSLBASE} \
--disable-uvfs
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} > 500000
LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4
CONFIGURE_ARGS+=--with-gmp=${PREFIX}
@@ -36,6 +34,8 @@ CONFIGURE_ARGS+=--with-gmp=/usr
.endif
MAN1= \
+ dirsearch.1 \
+ newaid.1 \
rex.1 \
sfsagent.1 \
sfskey.1 \
@@ -43,24 +43,33 @@ MAN1= \
MAN5= \
sfs_config.5 \
- sfs_users.5 \
- sfscd_config.5 \
- sfssd_config.5 \
sfs_srp_params.5 \
+ sfs_users.5 \
sfsauthd_config.5 \
- sfsrwsd_config.5
+ sfscd_config.5 \
+ sfsrwsd_config.5 \
+ sfssd_config.5
+
+MAN7= \
+ sfs.7
MAN8= \
+ funmount.8 \
sfsauthd.8 \
sfscd.8 \
sfsrwsd.8 \
- sfssd.8
+ sfssd.8 \
+ vidb.8
post-extract:
@${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/sfscd.sh > ${WRKSRC}/sfscd.sh
@${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/sfssd.sh > ${WRKSRC}/sfssd.sh
+pre-install:
+ PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL
+
post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sfsauthd/upgradedb.pl ${PREFIX}/lib/sfs-${PORTVERSION}/upgradedb.pl
${INSTALL_SCRIPT} ${WRKSRC}/sfscd.sh ${PREFIX}/etc/rc.d/sfscd.sh.sample
${INSTALL_SCRIPT} ${WRKSRC}/sfssd.sh ${PREFIX}/etc/rc.d/sfssd.sh.sample
${MKDIR} ${PREFIX}/etc/sfs
@@ -69,6 +78,7 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/share-doc-WELCOME ${PREFIX}/share/doc/sfs/WELCOME
${INSTALL_DATA} ${FILESDIR}/share-doc-README ${PREFIX}/share/doc/sfs/README
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sfs/README.packageblurb
+ ${INSTALL_DATA} ${WRKSRC}/README.0.7-upgrade ${PREFIX}/share/doc/sfs/README.0.7-upgrade
PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>