aboutsummaryrefslogtreecommitdiff
path: root/security/shishi
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-02 21:03:19 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-02 21:03:19 +0000
commit13fd01ce7fa69d1a907c2eb3ef60eec6bf643921 (patch)
tree79246ae86b7d5f76132b1ad3f291a011a3bd057c /security/shishi
parent2930ac304cd2f3d13f54ae533728da026ffaceca (diff)
Notes
Diffstat (limited to 'security/shishi')
-rw-r--r--security/shishi/Makefile21
-rw-r--r--security/shishi/files/patch-ltmain.sh15
2 files changed, 14 insertions, 22 deletions
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index 3294511aae63..05efd549eb37 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -8,23 +8,25 @@
PORTNAME= shishi
PORTVERSION= 0.0.16
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://josefsson.org/${PORTNAME}/releases/
+MASTER_SITES= http://josefsson.org/${PORTNAME}/releases/ \
+ ${MASTER_SITE_GNU_ALPHA}
MAINTAINER= ports@FreeBSD.org
COMMENT= A free implementation of the Kerberos 5 network security system
LIB_DEPENDS= idn.15:${PORTSDIR}/devel/libidn \
- gcrypt.12:${PORTSDIR}/security/libgcrypt \
tasn1.2:${PORTSDIR}/security/libtasn1
PKGMESSAGE= ${WRKDIR}/pkg-message
USE_PERL5_BUILD= yes
USE_GNOME= gnomehack gnometarget pkgconfig
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
+USE_ICONV= yes
+USE_GETOPT_LONG= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --disable-starttls \
--with-db-dir=/var/shishi
@@ -32,6 +34,12 @@ INSTALLS_SHLIB= yes
INFO= shishi
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.include "Makefile.man"
+.include <bsd.port.pre.mk>
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
@@ -50,5 +58,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include "Makefile.man"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/shishi/files/patch-ltmain.sh b/security/shishi/files/patch-ltmain.sh
deleted file mode 100644
index 7445dc9d716a..000000000000
--- a/security/shishi/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Mon Oct 20 00:50:48 2003
-+++ ltmain.sh Mon Oct 20 00:51:00 2003
-@@ -5457,10 +5457,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"