aboutsummaryrefslogtreecommitdiff
path: root/security/shttpscanner
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-09-24 20:18:15 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-09-24 20:18:15 +0000
commit35da930207d95ac96a072bd0f8d1c6e0479c84ae (patch)
treefca78c5ba629ec210ef5bd158093127f5812b35b /security/shttpscanner
parentdf68809bf718c742626f6bb6892850028e1a3de1 (diff)
downloadports-35da930207d95ac96a072bd0f8d1c6e0479c84ae.tar.gz
ports-35da930207d95ac96a072bd0f8d1c6e0479c84ae.zip
Notes
Diffstat (limited to 'security/shttpscanner')
-rw-r--r--security/shttpscanner/Makefile34
-rw-r--r--security/shttpscanner/distinfo3
-rw-r--r--security/shttpscanner/pkg-descr6
3 files changed, 43 insertions, 0 deletions
diff --git a/security/shttpscanner/Makefile b/security/shttpscanner/Makefile
new file mode 100644
index 000000000000..f53a7779b2cc
--- /dev/null
+++ b/security/shttpscanner/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: shttpscanner
+# Date created: 25 September 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shttpscanner
+PORTVERSION= 0.4
+CATEGORIES= security www
+MASTER_SITES= SF
+DISTNAME= sHTTPScanner_v${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Simple HTTP scanner
+
+USE_ZIP= yes
+USE_DOS2UNIX= yes
+
+PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/requests.txt %%DATADIR%%/subdomains.txt
+PLIST_DIRS= %%DATADIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -E '/^#define/s!([a-z]*\.txt)!${DATADIR}/\1!' ${WRKSRC}/${DISTNAME:L}.c
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} ${PTHREAD_CFLAGS} -o ${PORTNAME} ${DISTNAME:L}.c ${PTHREAD_LIBS}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL} -d ${DATADIR}/
+ @${INSTALL} ${WRKSRC}/requests.txt ${WRKSRC}/subdomains.txt ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/security/shttpscanner/distinfo b/security/shttpscanner/distinfo
new file mode 100644
index 000000000000..8d6a730d069a
--- /dev/null
+++ b/security/shttpscanner/distinfo
@@ -0,0 +1,3 @@
+MD5 (sHTTPScanner_v0.4.zip) = e4eb3b2cd600e6cc1216f027e18fc515
+SHA256 (sHTTPScanner_v0.4.zip) = e3a8ea23a534c8fc4c4348634922a601605b90c9e223a0d6c2fd836811ce565b
+SIZE (sHTTPScanner_v0.4.zip) = 19156
diff --git a/security/shttpscanner/pkg-descr b/security/shttpscanner/pkg-descr
new file mode 100644
index 000000000000..4b4658b267f3
--- /dev/null
+++ b/security/shttpscanner/pkg-descr
@@ -0,0 +1,6 @@
+Simple HTTP Scanner is a creation made for web site pen testing. You can
+check for directories and files on the remote web server and get some
+server information like the webserver running.
+
+WWW: http://sourceforge.net/projects/shttpscanner/
+Author: Paisterist <paisterist@users.sourceforge.net>