aboutsummaryrefslogtreecommitdiff
path: root/security/sig2dot
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-07 08:32:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-07 08:32:07 +0000
commit2ee5c985120f9df050a35c496df0d10ec316e30d (patch)
tree03094d965296d53c49c603f9377dc1d4f5bac271 /security/sig2dot
parent0e28e3c5e85aa7e9c21653853cc338c2dc1a801a (diff)
downloadports-2ee5c985120f9df050a35c496df0d10ec316e30d.tar.gz
ports-2ee5c985120f9df050a35c496df0d10ec316e30d.zip
Notes
Diffstat (limited to 'security/sig2dot')
-rw-r--r--security/sig2dot/Makefile31
-rw-r--r--security/sig2dot/distinfo1
-rw-r--r--security/sig2dot/pkg-comment1
-rw-r--r--security/sig2dot/pkg-descr6
-rw-r--r--security/sig2dot/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/security/sig2dot/Makefile b/security/sig2dot/Makefile
new file mode 100644
index 000000000000..e273b0122a8e
--- /dev/null
+++ b/security/sig2dot/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: sig2dot
+# Date created: Aug 8, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sig2dot
+PORTVERSION= 0.27
+CATEGORIES= security
+MASTER_SITES= http://www.chaosreigns.com/code/sig2dot/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .pl
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKDIR}
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/bin/perl|${PERL}|g" ${WRKSRC}/sig2dot.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sig2dot.pl ${PREFIX}/bin/sig2dot
+
+.include <bsd.port.mk>
diff --git a/security/sig2dot/distinfo b/security/sig2dot/distinfo
new file mode 100644
index 000000000000..63d35afa1e63
--- /dev/null
+++ b/security/sig2dot/distinfo
@@ -0,0 +1 @@
+MD5 (sig2dot.pl) = 37f2380ce9de0ab985167e22265c4520
diff --git a/security/sig2dot/pkg-comment b/security/sig2dot/pkg-comment
new file mode 100644
index 000000000000..a4a5d0c56f7f
--- /dev/null
+++ b/security/sig2dot/pkg-comment
@@ -0,0 +1 @@
+GPG/PGP Keyring Graph Generator
diff --git a/security/sig2dot/pkg-descr b/security/sig2dot/pkg-descr
new file mode 100644
index 000000000000..7d963fc5ac77
--- /dev/null
+++ b/security/sig2dot/pkg-descr
@@ -0,0 +1,6 @@
+sig2dot can be used to generate a graph of all of the signature relationships
+in a GPG/PGP keyring. It converts the output of "gpg --list-sigs" to a .dot
+file, which is a graph definition that can be rendered by springgraph or
+graphviz.
+
+WWW: http://www.chaosreigns.com/code/sig2dot/
diff --git a/security/sig2dot/pkg-plist b/security/sig2dot/pkg-plist
new file mode 100644
index 000000000000..be48b9195b8d
--- /dev/null
+++ b/security/sig2dot/pkg-plist
@@ -0,0 +1 @@
+bin/sig2dot