aboutsummaryrefslogtreecommitdiff
path: root/security/silktools/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-11-06 19:44:13 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-11-06 19:44:13 +0000
commitbc20ee94394c88c8a19fa0615c538ddc241d1a94 (patch)
tree51cb6e730cfc147eb04b45b823add4c3b5593a53 /security/silktools/Makefile
parentb010e86be43db2746aa108c8919829724daa8424 (diff)
Notes
Diffstat (limited to 'security/silktools/Makefile')
-rw-r--r--security/silktools/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/security/silktools/Makefile b/security/silktools/Makefile
index fd45500dbd85..43f832a52cd2 100644
--- a/security/silktools/Makefile
+++ b/security/silktools/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= silktools
-PORTVERSION= 3.8.1
-PORTREVISION= 1
+PORTVERSION= 3.9.0
CATEGORIES= security net
MASTER_SITES= http://tools.netsa.cert.org/releases/ \
http://redundancy.redundancy.org/mirror/
@@ -16,19 +15,15 @@ LIB_DEPENDS= liblzo2.so:${PORTSDIR}/archivers/lzo2 \
libfixbuf.so:${PORTSDIR}/net/libfixbuf
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-lzo=${LOCALBASE} --enable-packing-tools --with-python \
- --prefix=${STAGEDIR}/${PREFIX}
-MAKE_ARGS= CC="${CC}" GCC_FLAGS="" CFLAGS_RELEASE=""
+CONFIGURE_ARGS= --with-lzo=${LOCALBASE} --enable-packing-tools --with-python
USE_LDCONFIG= yes
USES= gmake perl5 pkgconfig python libtool
USE_PERL5= build
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= LOCALTIME
LOCALTIME_DESC= Use localtime instead of UTC
LOCALTIME_CONFIGURE_ON=--enable-localtime
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
-
.include <bsd.port.mk>