aboutsummaryrefslogtreecommitdiff
path: root/security/skipfish
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-06-30 02:27:43 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-06-30 02:27:43 +0000
commite40ec577f4ec65ec580ac1fc9e27399fce5ee86a (patch)
tree78dd44f6de5414cf75bf02b007a79d3f691fd754 /security/skipfish
parent72be30144872d511d12740a52ddd35cd703f7226 (diff)
downloadports-e40ec577f4ec65ec580ac1fc9e27399fce5ee86a.tar.gz
ports-e40ec577f4ec65ec580ac1fc9e27399fce5ee86a.zip
Notes
Diffstat (limited to 'security/skipfish')
-rw-r--r--security/skipfish/Makefile3
-rw-r--r--security/skipfish/distinfo4
-rw-r--r--security/skipfish/files/patch-Makefile16
-rw-r--r--security/skipfish/files/patch-sfscandiff8
-rw-r--r--security/skipfish/pkg-plist1
5 files changed, 18 insertions, 14 deletions
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
index 4656be611ae2..90d25529e54c 100644
--- a/security/skipfish/Makefile
+++ b/security/skipfish/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= skipfish
-PORTVERSION= 1.88b
+PORTVERSION= 2.00b
CATEGORIES= security www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
EXTRACT_SUFX= .tgz
@@ -31,6 +31,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/skipfish ${PREFIX}/bin/skipfish
+ ${INSTALL_SCRIPT} ${WRKSRC}/sfscandiff ${PREFIX}/bin/sfscandiff
(cd ${WRKSRC}/assets/ && ${COPYTREE_SHARE} . ${DATADIR}/assets/)
(cd ${WRKSRC}/dictionaries/ && ${COPYTREE_SHARE} . ${DATADIR}/dictionaries/)
.if !defined(NOPORTDOCS)
diff --git a/security/skipfish/distinfo b/security/skipfish/distinfo
index 22e484621a99..e43d9a5e2c6b 100644
--- a/security/skipfish/distinfo
+++ b/security/skipfish/distinfo
@@ -1,2 +1,2 @@
-SHA256 (skipfish-1.88b.tgz) = b564cb444d1cb095a5ef20dd2ddda79a04a75cdf38037ba82ed470a3b2bce281
-SIZE (skipfish-1.88b.tgz) = 187602
+SHA256 (skipfish-2.00b.tgz) = da4ba0137364c78bf8eedc9e3eff3b0588931c59ae3e04e9ba05caf4f9da2fbc
+SIZE (skipfish-2.00b.tgz) = 192957
diff --git a/security/skipfish/files/patch-Makefile b/security/skipfish/files/patch-Makefile
index dcf8023b8a2e..81cf5efb8f22 100644
--- a/security/skipfish/files/patch-Makefile
+++ b/security/skipfish/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2010-11-29 16:59:49.000000000 -0500
-+++ Makefile 2010-12-12 19:24:29.000000000 -0500
+--- ./Makefile.orig 2011-06-29 20:02:06.000000000 -0400
++++ ./Makefile 2011-06-29 20:02:49.000000000 -0400
@@ -26,12 +26,13 @@
INCFILES = alloc-inl.h string-inl.h debug.h types.h http_client.h \
database.h crawler.h analysis.h config.h report.h
@@ -8,15 +8,15 @@
+_LOCALBASE ?= ${LOCALBASE}
+CFLAGS_GEN = -Wall -funsigned-char -g -ggdb -I$(LOCALBASE)/include/ \
-I/opt/local/include/ $(CFLAGS) -DVERSION=\"$(VERSION)\"
- CFLAGS_DBG = -DLOG_STDERR=1 -DDEBUG_ALLOCATOR=1 $(CFLAGS_GEN)
+ CFLAGS_DBG = -DLOG_STDERR=1 -DDEBUG_ALLOCATOR=1 $(CFLAGS_GEN)
CFLAGS_OPT = -O3 -Wno-format $(CFLAGS_GEN)
-LDFLAGS += -L/usr/local/lib/ -L/opt/local/lib
-+LDFLAGS += -L$(LOCALBASE)/lib/
++LDFLAGS += -L$(LOCALBASE)/lib/
LIBS += -lcrypto -lssl -lidn -lz
all: $(PROGNAME)
-@@ -39,12 +40,12 @@
+@@ -39,12 +40,6 @@
$(PROGNAME): $(PROGNAME).c $(OBJFILES) $(INCFILES)
$(CC) $(LDFLAGS) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS_OPT) \
$(OBJFILES) $(LIBS)
@@ -26,12 +26,6 @@
- @echo "Having problems with your scans? Be sure to visit:"
- @echo "http://code.google.com/p/skipfish/wiki/KnownIssues"
- @echo
-+# @echo
-+# @echo "See dictionaries/README-FIRST to pick a dictionary for the tool."
-+# @echo
-+# @echo "Having problems with your scans? Be sure to visit:"
-+# @echo "http://code.google.com/p/skipfish/wiki/KnownIssues"
-+# @echo
debug: $(PROGNAME).c $(OBJFILES) $(INCFILES)
$(CC) $(LDFLAGS) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS_DBG) \
diff --git a/security/skipfish/files/patch-sfscandiff b/security/skipfish/files/patch-sfscandiff
new file mode 100644
index 000000000000..040b8ca72f98
--- /dev/null
+++ b/security/skipfish/files/patch-sfscandiff
@@ -0,0 +1,8 @@
+--- ./sfscandiff.orig 2011-06-29 20:06:17.000000000 -0400
++++ ./sfscandiff 2011-06-29 20:06:20.000000000 -0400
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ echo "sfscandiff - skipfish scan result comparator (lcamtuf@google.com)" 1>&2
+
diff --git a/security/skipfish/pkg-plist b/security/skipfish/pkg-plist
index 6f445c85ea0d..d6038701874d 100644
--- a/security/skipfish/pkg-plist
+++ b/security/skipfish/pkg-plist
@@ -1,4 +1,5 @@
bin/skipfish
+bin/sfscandiff
%%DATADIR%%/assets/COPYING
%%DATADIR%%/assets/i_high.png
%%DATADIR%%/assets/i_low.png