aboutsummaryrefslogtreecommitdiff
path: root/security/skipfish
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-12-15 03:08:12 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-12-15 03:08:12 +0000
commit3bc981f862daf26eea9576f10292d9b8acb415b9 (patch)
treeabb546ea2476f67ff676c1a15d01cd5952e5bbf3 /security/skipfish
parent9925eef7c4b5194b533fb1a490d6ed2abc1d62eb (diff)
downloadports-3bc981f862daf26eea9576f10292d9b8acb415b9.tar.gz
ports-3bc981f862daf26eea9576f10292d9b8acb415b9.zip
Notes
Diffstat (limited to 'security/skipfish')
-rw-r--r--security/skipfish/Makefile12
-rw-r--r--security/skipfish/distinfo4
-rw-r--r--security/skipfish/files/patch-Makefile36
-rw-r--r--security/skipfish/files/patch-report.c6
-rw-r--r--security/skipfish/files/patch-sfscandiff4
-rw-r--r--security/skipfish/files/patch-src__http_client.c10
-rw-r--r--security/skipfish/pkg-plist1
7 files changed, 43 insertions, 30 deletions
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
index be3045029f16..4d02ebe9d814 100644
--- a/security/skipfish/Makefile
+++ b/security/skipfish/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= skipfish
-PORTVERSION= 2.07b
+PORTVERSION= 2.10b
CATEGORIES= security www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
EXTRACT_SUFX= .tgz
@@ -16,8 +16,10 @@ COMMENT= A fully automated, active web application security reconnaissance tool
LICENSE= AL2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn
+LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
+ pcre:${PORTSDIR}/devel/pcre
+USE_GMAKE= yes
SUB_FILES= pkg-message
MAN1= skipfish.1
@@ -30,12 +32,12 @@ PORTDOCS= README COPYING ChangeLog
post-patch:
@${REINPLACE_CMD} -e 's:"skipfish.wl":"${DATADIR}/dictionaries/complete.wl":' \
- -e 's:"assets":"${DATADIR}/assets":' ${WRKSRC}/config.h
+ -e 's:"assets":"${DATADIR}/assets":' ${WRKSRC}/src/config.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/skipfish ${PREFIX}/bin/skipfish
- ${INSTALL_SCRIPT} ${WRKSRC}/sfscandiff ${PREFIX}/bin/sfscandiff
- ${INSTALL_MAN} ${WRKSRC}/skipfish.1 ${PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/tools/sfscandiff ${PREFIX}/bin/sfscandiff
+ ${INSTALL_MAN} ${WRKSRC}/doc/skipfish.1 ${PREFIX}/man/man1
(cd ${WRKSRC}/assets/ && ${COPYTREE_SHARE} . ${DATADIR}/assets/)
(cd ${WRKSRC}/dictionaries/ && ${COPYTREE_SHARE} . ${DATADIR}/dictionaries/)
.if !defined(NOPORTDOCS)
diff --git a/security/skipfish/distinfo b/security/skipfish/distinfo
index cfee6caf6158..aa62dd54cb04 100644
--- a/security/skipfish/distinfo
+++ b/security/skipfish/distinfo
@@ -1,2 +1,2 @@
-SHA256 (skipfish-2.07b.tgz) = eecfe8ecfd3dde191bae3dd31efde5d4c0d35fa5898d83865a4644031ae37d82
-SIZE (skipfish-2.07b.tgz) = 213582
+SHA256 (skipfish-2.10b.tgz) = 1a4fbc9d013f1f9b970946ea7228d943266127b7f4100c994ad26c82c5352a9e
+SIZE (skipfish-2.10b.tgz) = 244528
diff --git a/security/skipfish/files/patch-Makefile b/security/skipfish/files/patch-Makefile
index 81cf5efb8f22..27b31ffe5033 100644
--- a/security/skipfish/files/patch-Makefile
+++ b/security/skipfish/files/patch-Makefile
@@ -1,31 +1,33 @@
---- ./Makefile.orig 2011-06-29 20:02:06.000000000 -0400
-+++ ./Makefile 2011-06-29 20:02:49.000000000 -0400
-@@ -26,12 +26,13 @@
- INCFILES = alloc-inl.h string-inl.h debug.h types.h http_client.h \
- database.h crawler.h analysis.h config.h report.h
+--- ./Makefile.orig 2012-12-07 10:14:00.000000000 -0500
++++ ./Makefile 2012-12-07 10:15:06.000000000 -0500
+@@ -33,13 +33,14 @@
+ OBJFILES = $(patsubst %,$(SRCDIR)/%,$(SFILES))
+ INCFILES = $(patsubst %,$(SRCDIR)/%,$(IFILES))
-CFLAGS_GEN = -Wall -funsigned-char -g -ggdb -I/usr/local/include/ \
+- -I/opt/local/include/ $(CFLAGS) -DVERSION=\"$(VERSION)\"
+_LOCALBASE ?= ${LOCALBASE}
+CFLAGS_GEN = -Wall -funsigned-char -g -ggdb -I$(LOCALBASE)/include/ \
- -I/opt/local/include/ $(CFLAGS) -DVERSION=\"$(VERSION)\"
- CFLAGS_DBG = -DLOG_STDERR=1 -DDEBUG_ALLOCATOR=1 $(CFLAGS_GEN)
- CFLAGS_OPT = -O3 -Wno-format $(CFLAGS_GEN)
++ $(CFLAGS) -DVERSION=\"$(VERSION)\"
+ CFLAGS_DBG = -DLOG_STDERR=1 -DDEBUG_ALLOCATOR=1 \
+ $(CFLAGS_GEN)
+ CFLAGS_OPT = -O3 -Wno-format $(CFLAGS_GEN)
-LDFLAGS += -L/usr/local/lib/ -L/opt/local/lib
-+LDFLAGS += -L$(LOCALBASE)/lib/
- LIBS += -lcrypto -lssl -lidn -lz
++LDFLAGS += -L$(LOCALBASE)/lib
+ LIBS += -lcrypto -lssl -lidn -lz -lpcre
all: $(PROGNAME)
-@@ -39,12 +40,6 @@
- $(PROGNAME): $(PROGNAME).c $(OBJFILES) $(INCFILES)
- $(CC) $(LDFLAGS) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS_OPT) \
- $(OBJFILES) $(LIBS)
+@@ -47,12 +48,6 @@
+ $(PROGNAME): $(SRCDIR)/$(PROGNAME).c $(OBJFILES) $(INCFILES)
+ $(CC) $(LDFLAGS) $(SRCDIR)/$(PROGNAME).c -o $(PROGNAME) \
+ $(CFLAGS_OPT) $(OBJFILES) $(LIBS)
- @echo
-- @echo "See dictionaries/README-FIRST to pick a dictionary for the tool."
+- @echo "See doc/dictionaries.txt to pick a dictionary for the tool."
- @echo
- @echo "Having problems with your scans? Be sure to visit:"
- @echo "http://code.google.com/p/skipfish/wiki/KnownIssues"
- @echo
- debug: $(PROGNAME).c $(OBJFILES) $(INCFILES)
- $(CC) $(LDFLAGS) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS_DBG) \
+ debug: $(SRCDIR)/$(PROGNAME).c $(OBJFILES) $(INCFILES)
+ $(CC) $(LDFLAGS) $(SRCDIR)/$(PROGNAME).c -o $(PROGNAME) \
diff --git a/security/skipfish/files/patch-report.c b/security/skipfish/files/patch-report.c
index 1c2ed9d002a7..d28f1f935ab6 100644
--- a/security/skipfish/files/patch-report.c
+++ b/security/skipfish/files/patch-report.c
@@ -1,6 +1,6 @@
---- ./report.c.orig 2010-04-09 00:36:30.000000000 +0200
-+++ ./report.c 2010-04-11 19:05:39.000000000 +0200
-@@ -741,7 +741,7 @@
+--- ./src/report.c.orig 2012-09-24 11:55:23.000000000 -0400
++++ ./src/report.c 2012-09-24 11:55:32.000000000 -0400
+@@ -799,7 +799,7 @@
static void copy_static_code(u8* out_dir) {
struct dirent** d;
ca_out_dir = out_dir;
diff --git a/security/skipfish/files/patch-sfscandiff b/security/skipfish/files/patch-sfscandiff
index 040b8ca72f98..b1c967bb1eaf 100644
--- a/security/skipfish/files/patch-sfscandiff
+++ b/security/skipfish/files/patch-sfscandiff
@@ -1,5 +1,5 @@
---- ./sfscandiff.orig 2011-06-29 20:06:17.000000000 -0400
-+++ ./sfscandiff 2011-06-29 20:06:20.000000000 -0400
+--- ./tools/sfscandiff.orig 2011-06-29 20:06:17.000000000 -0400
++++ ./tools/sfscandiff 2011-06-29 20:06:20.000000000 -0400
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
diff --git a/security/skipfish/files/patch-src__http_client.c b/security/skipfish/files/patch-src__http_client.c
new file mode 100644
index 000000000000..640234f4cf6b
--- /dev/null
+++ b/security/skipfish/files/patch-src__http_client.c
@@ -0,0 +1,10 @@
+--- ./src/http_client.c.orig 2012-09-24 12:05:51.000000000 -0400
++++ ./src/http_client.c 2012-09-24 12:05:58.000000000 -0400
+@@ -44,6 +44,7 @@
+ #include "alloc-inl.h"
+ #include "string-inl.h"
+ #include "database.h"
++#include "config.h"
+
+ #include "http_client.h"
+
diff --git a/security/skipfish/pkg-plist b/security/skipfish/pkg-plist
index d6038701874d..5828d2f1c959 100644
--- a/security/skipfish/pkg-plist
+++ b/security/skipfish/pkg-plist
@@ -24,7 +24,6 @@ bin/sfscandiff
%%DATADIR%%/assets/p_unknown.png
%%DATADIR%%/assets/p_value.png
%%DATADIR%%/assets/sf_name.png
-%%DATADIR%%/dictionaries/README-FIRST
%%DATADIR%%/dictionaries/complete.wl
%%DATADIR%%/dictionaries/medium.wl
%%DATADIR%%/dictionaries/extensions-only.wl