aboutsummaryrefslogtreecommitdiff
path: root/security/sks
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-01-25 12:10:59 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-01-25 12:10:59 +0000
commit41fd74b1d12c1805bd54d4896c71c82d132bf377 (patch)
tree3d26cc7c134069aa1646a9ec51ae94272cba7a2b /security/sks
parent0d3c92e18e0ddae610ff1795a48c3044f71e14e9 (diff)
Respect CC and CFLAGS
Notes
Notes: svn path=/head/; revision=341014
Diffstat (limited to 'security/sks')
-rw-r--r--security/sks/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/sks/Makefile b/security/sks/Makefile
index 77ad7cd267a1..9f8ead58da45 100644
--- a/security/sks/Makefile
+++ b/security/sks/Makefile
@@ -30,12 +30,16 @@ post-extract:
@${REINPLACE_CMD} 's/-ccopt -pg //' ${WRKSRC}/Makefile
@cd ${WRKSRC} && ${RM} -f .depend
+post-patch:
+ @${REINPLACE_CMD} '/^CC=/d; /^CFLAGS=/s/=/+=/' \
+ ${WRKSRC}/Makefile ${WRKSRC}/bdb/Makefile
+
pre-build:
@cd ${WRKSRC} && test -f .depend || ${GMAKE} dep
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} BUGS README.md TODO UPGRADING \
+ cd ${WRKSRC} && ${INSTALL_DATA} BUGS README.md TODO UPGRADING \
${STAGEDIR}${DOCSDIR}
@cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} sks sks_add_mail