aboutsummaryrefslogtreecommitdiff
path: root/security/sks
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2008-06-21 15:12:11 +0000
committerJohan van Selst <johans@FreeBSD.org>2008-06-21 15:12:11 +0000
commite59058f328f6159a084e52b051266e96873ee84d (patch)
tree2e96db880517fcad9df499255d5ad9a63d87217f /security/sks
parent8d2a56b9917d17a68e3f2c2f31dd33c2120b0091 (diff)
downloadports-e59058f328f6159a084e52b051266e96873ee84d.tar.gz
ports-e59058f328f6159a084e52b051266e96873ee84d.zip
Notes
Diffstat (limited to 'security/sks')
-rw-r--r--security/sks/Makefile32
-rw-r--r--security/sks/distinfo6
-rw-r--r--security/sks/files/patch-Makefile19
-rw-r--r--security/sks/files/patch-bdb_bdb_stubs.c11
-rw-r--r--security/sks/files/patch-mRandom.ml11
-rw-r--r--security/sks/files/patch-number.ml11
-rw-r--r--security/sks/files/patch-sks_build.sh8
-rw-r--r--security/sks/files/sks.numerix.patch50
-rw-r--r--security/sks/pkg-descr6
-rw-r--r--security/sks/pkg-message8
10 files changed, 27 insertions, 135 deletions
diff --git a/security/sks/Makefile b/security/sks/Makefile
index 1876b6a70166..f05e50c6530f 100644
--- a/security/sks/Makefile
+++ b/security/sks/Makefile
@@ -6,42 +6,36 @@
#
PORTNAME= sks
-PORTVERSION= 1.0.9
-PORTREVISION= 2
+PORTVERSION= 1.1.0
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITES= http://minskyprimus.net/sks/releases/
MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .tgz
MAINTAINER= johans@stack.nl
COMMENT= Synchronizing Key Server, a fast OpenPGP keyserver
-BUILD_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml-nox11
-LIB_DEPENDS= db-4.2:${PORTSDIR}/databases/db42
+USE_OCAML= yes
+USE_BDB= 46+
+USE_PERL5_BUILD=yes
USE_GMAKE= yes
-MAKE_ENV= BDBINCLUDE="-I${LOCALBASE}/include/db42" \
- BDBLIB="-L${LOCALBASE}/lib" \
- LIBDB="-ldb-4.2" \
+MAKE_ENV= BDBINCLUDE="-I${BDB_INCLUDE_DIR}" \
+ BDBLIB="-L${BDB_LIB_DIR}" \
+ LIBDB="-l${BDB_LIB_NAME}" \
MANDIR="${MANPREFIX}/man"
-ALL_TARGET= all sks.8
-USE_PERL5_BUILD= yes
+ALL_TARGET= all sks.8.gz
PLIST_FILES= bin/sks bin/sks_add_mail bin/sks_build.sh
MAN8= sks.8
-PORTDOCS= ANNOUNCEMENT BUGS README TODO
+MANCOMPRESSED= yes
+PORTDOCS= BUGS README TODO
-post-patch:
- @${CP} ${FILESDIR}/sks.numerix.patch ${WRKDIR}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sks ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/sks_add_mail ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/sks_build.sh ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/sks.8 ${MAN8PREFIX}/man/man8
+post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/security/sks/distinfo b/security/sks/distinfo
index 2309232e5da2..7d51c73469b3 100644
--- a/security/sks/distinfo
+++ b/security/sks/distinfo
@@ -1,3 +1,3 @@
-MD5 (sks-1.0.9.tgz) = 90d42c61de9121aa5102739b2ca6c952
-SHA256 (sks-1.0.9.tgz) = 3cfe562bc98526807c7a7480dd9c521f6a54e1aa536764e7ef8a84dfd3e3c0f9
-SIZE (sks-1.0.9.tgz) = 925362
+MD5 (sks-1.1.0.tgz) = e774100ccb73044f0f6009dc75d67045
+SHA256 (sks-1.1.0.tgz) = f851a6375820595d7a7b1ef3b4ec7322ed27862215fa53efa74f76d9fd7626f2
+SIZE (sks-1.1.0.tgz) = 272456
diff --git a/security/sks/files/patch-Makefile b/security/sks/files/patch-Makefile
deleted file mode 100644
index a69a106d2a43..000000000000
--- a/security/sks/files/patch-Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile.orig Thu Oct 21 06:56:02 2004
-+++ Makefile Tue Nov 9 16:35:02 2004
-@@ -148,7 +148,7 @@ sks.8.gz: sks.8
- gzip -f sks.8
-
- sks.8: sks.pod
-- pod2man -c "SKS OpenPGP Key server" --section 8 -r 0.1 -name sks sks.pod sks.8
-+ pod2man -c "SKS OpenPGP Key server" --section 8 -r 0.1 sks.pod > sks.8
-
- sks: $(LIBS) $(ALLOBJS) sks.cmx
- $(OCAMLOPT) -o sks $(OCAMLOPTFLAGS) $(ALLOBJS) sks.cmx
-@@ -294,6 +294,7 @@ NXDIR=numerix-0.19
-
- $(NXDIR)/READ.ME:
- tar xvmfz $(NXDIR)-3.tar.gz
-+ patch -p0 < ../sks.numerix.patch
-
- $(NXDIR)/config.status: $(NXDIR)/READ.ME
- cd $(NXDIR) && \
diff --git a/security/sks/files/patch-bdb_bdb_stubs.c b/security/sks/files/patch-bdb_bdb_stubs.c
deleted file mode 100644
index af92cf2c40ab..000000000000
--- a/security/sks/files/patch-bdb_bdb_stubs.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- bdb/bdb_stubs.c.orig Thu Oct 21 04:56:02 2004
-+++ bdb/bdb_stubs.c Sat Nov 20 16:33:08 2004
-@@ -223,7 +223,7 @@
-
- // Declaration of flag enums in ocaml must be in same order as in C
-
--static int dbenv_create_flags[] = { DB_CLIENT };
-+static int dbenv_create_flags[] = { DB_RPCCLIENT };
-
- //+
- //+ type create_flag = CLIENT
diff --git a/security/sks/files/patch-mRandom.ml b/security/sks/files/patch-mRandom.ml
deleted file mode 100644
index c240c6d674e5..000000000000
--- a/security/sks/files/patch-mRandom.ml
+++ /dev/null
@@ -1,11 +0,0 @@
---- mRandom.ml.orig Thu Oct 21 06:56:03 2004
-+++ mRandom.ml Tue Nov 9 16:34:27 2004
-@@ -92,7 +92,7 @@ struct
-
- (* Low-entropy system-dependent initialisation. *)
-
-- external random_seed: unit -> int = "sys_random_seed"
-+ external random_seed: unit -> int = "caml_sys_random_seed"
-
- let self_init () = init (random_seed())
-
diff --git a/security/sks/files/patch-number.ml b/security/sks/files/patch-number.ml
deleted file mode 100644
index 4026848573c3..000000000000
--- a/security/sks/files/patch-number.ml
+++ /dev/null
@@ -1,11 +0,0 @@
---- number.ml Thu Oct 21 04:56:03 2004
-+++ number.ml Thu Nov 25 00:25:35 2004
-@@ -18,7 +18,7 @@
- (** Basic operations and definitions for multi-precistion integers. *)
-
- (* Change to Dlong for non x86 platforms *)
--module Nx = Numerix.Slong
-+module Nx = Numerix.Clong
-
- let two = Nx.of_int 2
- let one = Nx.of_int 1
diff --git a/security/sks/files/patch-sks_build.sh b/security/sks/files/patch-sks_build.sh
deleted file mode 100644
index 0e409739772f..000000000000
--- a/security/sks/files/patch-sks_build.sh
+++ /dev/null
@@ -1,8 +0,0 @@
---- sks_build.sh.orig Thu Oct 21 06:56:04 2004
-+++ sks_build.sh Tue Nov 9 16:34:27 2004
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # SKS build script.
- # cd to directory with "dump" subdirectory, and run
diff --git a/security/sks/files/sks.numerix.patch b/security/sks/files/sks.numerix.patch
deleted file mode 100644
index 057802339285..000000000000
--- a/security/sks/files/sks.numerix.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- numerix-0.19/configure Sat Oct 16 15:47:19 2004
-+++ numerix-0.19/configure Sat Oct 16 15:38:02 2004
-@@ -4337,6 +4337,7 @@
- echo "$as_me:$LINENO: checking for Ocaml version" >&5
- echo $ECHO_N "checking for Ocaml version... $ECHO_C" >&6
- ocaml_version=`config/camlconf $ocamlc version`
-+ ocaml_version=${ocaml_version%%.*}
- echo "$as_me:$LINENO: result: $ocaml_version" >&5
- echo "${ECHO_T}$ocaml_version" >&6
- echo "$as_me:$LINENO: checking for Ocaml directory" >&5
---- numerix-0.19/config/config.sub Thu Nov 25 00:33:31 2004
-+++ numerix-0.19/config/config.sub Thu Nov 25 00:35:01 2004
-@@ -155,7 +155,7 @@
- | alpha | alphaev5 | alphaev56 | we32k | ns16k | clipper \
- | i370 | sh | powerpc | powerpcle | 1750a | dsp16xx | pdp11 \
- | mips64 | mipsel | mips64el | mips64orion | mips64orionel \
-- | mipstx39 | mipstx39el \
-+ | mipstx39 | mipstx39el | amd64 | ia64 \
- | sparc | sparclet | sparclite | sparc64 | v850)
- basic_machine=$basic_machine-unknown
- ;;
-@@ -181,7 +181,7 @@
- | sparclite-* | pdp11-* | sh-* | powerpc-* | powerpcle-* \
- | sparc64-* | mips64-* | mipsel-* \
- | mips64el-* | mips64orion-* | mips64orionel-* \
-- | mipstx39-* | mipstx39el-* \
-+ | mipstx39-* | mipstx39el-* | amd64-* | ia64-* \
- | f301-*)
- ;;
- # Recognize the various machine names and aliases which stand
---- numerix-0.19/lib/kernel/string.c Sat Oct 16 15:47:19 2004
-+++ numerix-0.19/lib/kernel/string.c Sat Oct 16 15:14:17 2004
-@@ -38,7 +38,7 @@
- longueur l;
-
- /* saute les blancs et le signe */
-- while isspace(*s) s++;
-+ while (isspace(*s)) s++;
- if ((*s == '+') || (*s == '-')) s++;
-
- /* compte le nombre de chiffres décimaux */
-@@ -83,7 +83,7 @@
- long i,j,l,n;
-
- /* saute les blancs et le signe */
-- while isspace(*s) s++;
-+ while (isspace(*s)) s++;
- switch(*s) {
- case '-' : sa = SIGN_m;
- case '+' : s++;
diff --git a/security/sks/pkg-descr b/security/sks/pkg-descr
index 220d4ceeb7b6..0c549ec4c641 100644
--- a/security/sks/pkg-descr
+++ b/security/sks/pkg-descr
@@ -6,8 +6,8 @@ key submitted to one SKS server will quickly be distributed to all key
servers; and even wildly out-of-date servers, or servers that experience
spotty connectivity, can fully synchronize with rest of the system.
-Refer to the online wiki for pointers on downloading a full copy of the
-public PGP databse (about 2Gb) and on customising the local configuration
-http://documentation.penguin.de/cgi-bin/twiki/view/SKSKeyserver/WebHome
+Refer to the online references for pointers on downloading a full copy of
+the public PGP databse (about 2Gb) and on tweaking the your configuration.
+http://www.keysigning.org/sks/ may help you getting started.
WWW: http://www.nongnu.org/sks/
diff --git a/security/sks/pkg-message b/security/sks/pkg-message
new file mode 100644
index 000000000000..b23e23c70a3d
--- /dev/null
+++ b/security/sks/pkg-message
@@ -0,0 +1,8 @@
+
+=> When updating from an sks version < 1.1 be aware that the pgp key
+=> database files are not compatible: make a full dump of your data
+=> before updating and rebuild the database files afterwards.
+
+When installing for the first time, you will need to obtain a pgp
+key database dump from somewhere and build database files from this.
+http://www.keysigning.org/sks/ may help you getting started.