aboutsummaryrefslogtreecommitdiff
path: root/security/slush/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-09 17:50:07 +0000
committerSteve Price <steve@FreeBSD.org>1999-05-09 17:50:07 +0000
commit754ea881597bf8ee78f2777812190c09b28c6fdc (patch)
tree5ad716d93c2f653b8c1b5841f4fe7c1cbb340d86 /security/slush/Makefile
parent7acd813c7ac469d074c0bf76ae7d54b8acebb330 (diff)
Notes
Diffstat (limited to 'security/slush/Makefile')
-rw-r--r--security/slush/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/security/slush/Makefile b/security/slush/Makefile
new file mode 100644
index 000000000000..5cbfdfaaa112
--- /dev/null
+++ b/security/slush/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: slush
+# Version required: 0.1.0
+# Date created: Sun May 3, 1999
+# Whom: shipley@dis.org
+#
+# $Id$
+#
+#DISTDIR= /var/tmp/ # for debuging
+
+DISTNAME= slush-0_1_0_tar
+PKGNAME= slush-0.1.0
+CATEGORIES= security net
+MASTER_SITES= ftp://www.dis.org/pub/Security/
+EXTRACT_SUFX= .gz
+
+MAINTAINER= shipley@dis.org
+
+BUILD_DEPENDS= openssl:${PORTSDIR}/security/openssl
+
+#MAN= slush.1
+
+GNU_CONFIGURE= yes
+
+#NOPROFILE= true
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} <= 300000
+BROKEN= does not build
+.endif
+
+WRKSRC= ${WRKDIR}/slush-0.1.0
+.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
+MAKE_ENV+= EXTRA_SSL_LIBS="-lRSAglue -lrsaref"
+.endif
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/control.txt ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/HISTORY ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/slush
+ ${INSTALL_MAN} ${WRKSRC}/COPYING ${PREFIX}/share/doc/slush
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/slush ${PREFIX}/bin/slush
+ ${INSTALL_PROGRAM} ${WRKSRC}/slushd ${PREFIX}/sbin/slushd
+
+.include <bsd.port.post.mk>