aboutsummaryrefslogtreecommitdiff
path: root/security/smtpscan/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-02 16:01:37 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-02 16:01:37 +0000
commit373301c87d2c94e50de6b4403ddfeff9669b75a9 (patch)
tree35e46455fbdf9457ff5db40ac5a0712595cc8cbc /security/smtpscan/Makefile
parente37090f07adb648bbd254389f83306f638fa4057 (diff)
Notes
Diffstat (limited to 'security/smtpscan/Makefile')
-rw-r--r--security/smtpscan/Makefile43
1 files changed, 32 insertions, 11 deletions
diff --git a/security/smtpscan/Makefile b/security/smtpscan/Makefile
index 23899e0e81e8..b0a3af5c751a 100644
--- a/security/smtpscan/Makefile
+++ b/security/smtpscan/Makefile
@@ -1,24 +1,45 @@
-# New ports collection makefile for: smtpscan
-# Date created: 1 decembre 2002
-# Whom: Hubert Tournier <hubert@frbsd.org>
-#
+# Created by: Hubert Tournier <hubert@frbsd.org>
# $FreeBSD$
-#
PORTNAME= smtpscan
PORTVERSION= 0.5
PORTREVISION= 2
CATEGORIES= security mail perl5
-MASTER_SITES= http://www.frbsd.org/dist/
+MASTER_SITES= PACKETSTORM/UNIX/scanners \
+ http://www.frbsd.org/dist/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A remote SMTP server version detector
+COMMENT= Remote SMTP server version detector
+
+LICENSE= GPLv2
RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
-USE_PERL5= yes
-MAN1= smtpscan.1
-MAKEFILE=${FILESDIR}/Makefile
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+USE_PERL5_RUN= yes
+
+MAN1= smtpscan.1
+PLIST_FILES= bin/smtpscan \
+ %%DATADIR%%/fingerprints \
+ %%DATADIR%%/tests
+PLIST_DIRS= %%DATADIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^#!.*|#!${PERL}| ; \
+ s|/usr/local/share|${PREFIX}/share| ; \
+ s|@VERSION@|${PORTVERSION}|' ${WRKSRC}/src/smtpscan
+ @${REINPLACE_CMD} -e \
+ 's|@VERSION@|${PORTVERSION}| ; \
+ s|@prefix@|${PREFIX}/share|' ${WRKSRC}/docs/man/smtpscan.1
+
+do-install:
+ (cd ${WRKSRC}/src && ${INSTALL_SCRIPT} smtpscan ${PREFIX}/bin)
+ (cd ${WRKSRC}/docs/man \
+ && ${INSTALL_MAN} smtpscan.1 ${MANPREFIX}/man/man1)
+ @${MKDIR} ${DATADIR}
+ (cd ${WRKSRC}/src && ${INSTALL_SCRIPT} fingerprints tests ${DATADIR})
.include <bsd.port.mk>