aboutsummaryrefslogtreecommitdiff
path: root/security/snoopy
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-24 20:49:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-24 20:49:01 +0000
commitdca829ccd17eb29b2b3a1805d23d08a265f36be6 (patch)
tree41a4c15648d56ffeed82df8f4272acc3469ec8d8 /security/snoopy
parent50537324340b3f6075cdf36be9430f0c0099965d (diff)
downloadports-dca829ccd17eb29b2b3a1805d23d08a265f36be6.tar.gz
ports-dca829ccd17eb29b2b3a1805d23d08a265f36be6.zip
Notes
Diffstat (limited to 'security/snoopy')
-rw-r--r--security/snoopy/Makefile2
-rw-r--r--security/snoopy/distinfo6
-rw-r--r--security/snoopy/files/patch-tests-bin-snoopy-test-threads.c11
3 files changed, 4 insertions, 15 deletions
diff --git a/security/snoopy/Makefile b/security/snoopy/Makefile
index 90d256aba628..f0a834151e1b 100644
--- a/security/snoopy/Makefile
+++ b/security/snoopy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= snoopy
-PORTVERSION= 2.4.8
+PORTVERSION= 2.4.9
CATEGORIES= security
MASTER_SITES= https://github.com/a2o/snoopy/releases/download/snoopy-${PORTVERSION}/
diff --git a/security/snoopy/distinfo b/security/snoopy/distinfo
index cd4f4e5bc9eb..3e9f6e3334e2 100644
--- a/security/snoopy/distinfo
+++ b/security/snoopy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1605901614
-SHA256 (snoopy-2.4.8.tar.gz) = 83c0443915658765b8e48e2f744a1fce928dd20156f04d5f8f8500f24cf2e6fc
-SIZE (snoopy-2.4.8.tar.gz) = 625914
+TIMESTAMP = 1606243325
+SHA256 (snoopy-2.4.9.tar.gz) = c3b63c99292b2cec9a89a0e79ce2459396442b42124b2f6b73ec5c6f4c1f36bd
+SIZE (snoopy-2.4.9.tar.gz) = 627480
diff --git a/security/snoopy/files/patch-tests-bin-snoopy-test-threads.c b/security/snoopy/files/patch-tests-bin-snoopy-test-threads.c
deleted file mode 100644
index 3e53630252c7..000000000000
--- a/security/snoopy/files/patch-tests-bin-snoopy-test-threads.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- tests/bin/snoopy-test-threads.c.orig 2017-12-26 01:38:15.298217000 +0800
-+++ tests/bin/snoopy-test-threads.c 2017-12-26 01:41:42.177506000 +0800
-@@ -307,7 +307,7 @@
- int randomNr;
-
- // Seed
-- rndSeed = (unsigned int) (pthread_self() + getpid() + syscall(SYS_gettid) + time(NULL));
-+ rndSeed = (unsigned int) ((unsigned int)pthread_self() + getpid() + time(NULL));
- srand(rndSeed);
-
- // Generate