aboutsummaryrefslogtreecommitdiff
path: root/security/snort/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /security/snort/Makefile
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'security/snort/Makefile')
-rw-r--r--security/snort/Makefile25
1 files changed, 19 insertions, 6 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index d4082231fab8..46bd022e9671 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -49,6 +49,19 @@ DOCS= RELEASE.NOTES doc/AUTHORS doc/BUGS doc/CREDITS \
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-sf_snort_plugin_api.h
.endif
+.if defined(WITH_FLEXRESP)
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+.elif defined(WITH_FLEXRESP2)
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+.endif
+
+.if exists(${LIBNET_CONFIG})
+LIBNET_CFLAGS!= ${LIBNET_CONFIG} --cflags
+LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
+LIBNET_INCDIR= ${LIBNET_CFLAGS:M-I*:S/-I//}
+LIBNET_LIBDIR= ${LIBNET_CFLAGS:M-L*:S/-L//}
+.endif
+
.if !defined(WITHOUT_DYNAMIC)
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
@@ -62,21 +75,21 @@ PLIST_SUB+= DYNAMIC="@comment "
.if defined(WITH_FLEXRESP2)
IGNORE= options FLEXRESP and FLEXRESP2 are mutually exclusive
.endif
-BUILD_DEPENDS+= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
CONFIGURE_ARGS+= --enable-flexresp \
- --with-libnet-includes=${LOCALBASE}/include \
- --with-libnet-libraries=${LOCALBASE}/lib
+ --with-libnet-includes=${LIBNET_INCDIR} \
+ --with-libnet-libraries=${LIBNET_LIBDIR}
.endif
.if defined(WITH_FLEXRESP2)
BROKEN= FLEXRESP2 patch file does not incorporate cleanly
PATCH_SITES+= http://cerberus.sourcefire.com/~jeff/archives/snort/sp_respond2/
PATCHFILES+= sp_respond2.diff.gz
-BUILD_DEPENDS+= libnet*>=1.1.2.1,1:${PORTSDIR}/net/libnet \
+BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
libdnet*>=1.10_1:${PORTSDIR}/net/libdnet
CONFIGURE_ARGS+= --enable-flexresp2 \
- --with-libnet-includes=${LOCALBASE}/include \
- --with-libnet-libraries=${LOCALBASE}/lib
+ --with-libnet-includes=${LIBNET_INCDIR} \
+ --with-libnet-libraries=${LIBNET_LIBDIR}
.endif
.if defined(WITH_MYSQL)