aboutsummaryrefslogtreecommitdiff
path: root/security/snort
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-04-10 10:49:33 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-04-10 10:49:33 +0000
commit7bcacde9634dcf42fa1ba09ac302e416b2bdc225 (patch)
tree498fbd3c15192e981608fcb8b620e08a235f7a69 /security/snort
parent51cbaf554a7dbd150ba46a17bab98676dd82d6c4 (diff)
downloadports-7bcacde9634dcf42fa1ba09ac302e416b2bdc225.tar.gz
ports-7bcacde9634dcf42fa1ba09ac302e416b2bdc225.zip
Notes
Diffstat (limited to 'security/snort')
-rw-r--r--security/snort/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index e52fe63e6577..a330de69d9a9 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -26,21 +26,18 @@ LDFLAGS+= "-L${LOCALBASE}/lib"
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+=--with-mysql-includes=${LOCALBASE}/include/mysql \
- --with-mysql-libraries=${LOCALBASE}/lib/mysql
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}
.endif
.if defined(WITH_ODBC)
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
-CONFIGURE_ARGS+=--with-unixodbc-includes=${LOCALBASE}/include \
- --with-unixodbc-libraries=${LOCALBASE}/lib
+CONFIGURE_ARGS+=--with-odbc=${LOCALBASE}
LDFLAGS+= ${PTHREAD_LIBS}
.endif
.if defined(WITH_POSTGRES)
-LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql
-CONFIGURE_ARGS+=--with-libpq-includes=${LOCALBASE}/pgsql/include \
- --with-libpq-libraries=${LOCALBASE}/pgsql/lib
+LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
+CONFIGURE_ARGS+=--with-postgresql=${LOCALBASE}/pgsql
.if exists(/usr/lib/libssl.a) && exists(/usr/lib/libcrypto.a)
LDFLAGS+= -lssl -lcrypto
.endif