aboutsummaryrefslogtreecommitdiff
path: root/security/snortsnarf/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-07-30 00:24:02 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-07-30 00:24:02 +0000
commit6b38a920240ae3e867521f09fe2c4cbd1f8a7316 (patch)
tree3ac14288c105c90c2f1bf1251967d4d79f5ab9d4 /security/snortsnarf/Makefile
parent492002c8fb8b486cc02ad52f35f4dddb40abdb9d (diff)
downloadports-6b38a920240ae3e867521f09fe2c4cbd1f8a7316.tar.gz
ports-6b38a920240ae3e867521f09fe2c4cbd1f8a7316.zip
Notes
Diffstat (limited to 'security/snortsnarf/Makefile')
-rw-r--r--security/snortsnarf/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/security/snortsnarf/Makefile b/security/snortsnarf/Makefile
new file mode 100644
index 000000000000..496eccec949f
--- /dev/null
+++ b/security/snortsnarf/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: snortsnarf
+# Date created: 29 July 2001
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snortsnarf
+PORTVERSION= 010523
+CATEGORIES= security
+MASTER_SITES= http://www.silicondefense.com/software/snortsnarf/
+DISTNAME= SnortSnarf-052301.1
+
+MAINTAINER= kris@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Time/JulianDay.pm:${PORTSDIR}/devel/p5-Time
+
+NO_BUILD= yes
+
+do-install:
+ ${SED} s,%LOCALBASE%,${LOCALBASE}, < ${WRKSRC}/snortsnarf.pl > ${WRKSRC}/snortsnarf
+ ${INSTALL_SCRIPT} ${WRKSRC}/snortsnarf ${LOCALBASE}/bin/snortsnarf
+ ${MKDIR} ${LOCALBASE}/libdata/snortsnarf
+ ${MKDIR} ${LOCALBASE}/libdata/snortsnarf/SnortSnarf
+.for i in IPAddrContact.pm ann_xml.pl web_utils.pl xml_help.pl
+ ${INSTALL_DATA} ${WRKSRC}/include/${i} ${LOCALBASE}/libdata/snortsnarf/
+.endfor
+.for i in AlertBase.pm HTMLOutput.pm MemTimeBase.pm MultiStore.pm \
+ MemPacket.pm HTMLMemStorage.pm Filtering.pm PacketBase.pm \
+ AllMods.pm BasicFilters.pm KnownEquiv.pm SnortFileInput.pm \
+ HTMLAnomMemStorage.pm Input.pm SorterBase.pm Sort.pm \
+ StorageBase.pm MemAlert.pm BasicSorters.pm Filter.pm \
+ SnortRules.pm MemStorage.pm
+ ${INSTALL_DATA} ${WRKSRC}/include/SnortSnarf/${i} ${LOCALBASE}/libdata/snortsnarf/SnortSnarf/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${LOCALBASE}/share/doc/snortsnarf
+.for i in README Usage
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${LOCALBASE}/share/doc/snortsnarf
+.endfor
+.endif
+
+.include <bsd.port.mk>