aboutsummaryrefslogtreecommitdiff
path: root/security/softhsm/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-25 10:31:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-25 10:31:40 +0000
commitbd57460c3924be25ad437a83415955c422a223a4 (patch)
treeeb879f95271bc1ec7302e74b822549c6fcc14c3b /security/softhsm/Makefile
parentcefb42bb59dff64984ffae16ad9c632e7e389e40 (diff)
downloadports-bd57460c3924be25ad437a83415955c422a223a4.tar.gz
ports-bd57460c3924be25ad437a83415955c422a223a4.zip
Notes
Diffstat (limited to 'security/softhsm/Makefile')
-rw-r--r--security/softhsm/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/softhsm/Makefile b/security/softhsm/Makefile
new file mode 100644
index 000000000000..4b18a287a16f
--- /dev/null
+++ b/security/softhsm/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: softhsm
+# Date created: 15 December 2009
+# Whom: Jaap Akkerhuis <jaap@NLnetLabs.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= softhsm
+PORTVERSION= 1.1.2
+CATEGORIES= security
+MASTER_SITES= http://www.opendnssec.org/files/source/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jaap@NLnetLabs.nl
+COMMENT= A software implementation of a Hardware Security Module (HSM)
+
+LIB_DEPENDS= botan:${PORTSDIR}/security/botan
+LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
+
+GNU_CONFIGURE= yes
+
+USE_LDCONFIG= yes
+
+MAN1= softhsm.1 softhsm-keyconv.1
+MAN5= softhsm.conf.5
+
+PLIST_FILES= bin/softhsm \
+ bin/softhsm-keyconv \
+ lib/libsofthsm.a \
+ lib/libsofthsm.la \
+ lib/libsofthsm.so \
+ lib/libsofthsm.so.1 \
+ etc/softhsm.conf \
+ etc/softhsm.conf.sample
+
+.include <bsd.port.mk>