aboutsummaryrefslogtreecommitdiff
path: root/security/softhsm2/Makefile
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2017-07-17 15:18:36 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2017-07-17 15:18:36 +0000
commit4e049717137aa486b6b860ba779bec448bc9d50e (patch)
treeac0169db69dc7ceda4d280fe139a5b07de657cf6 /security/softhsm2/Makefile
parent09bc85bbd9846c44c456fc79d971aea6d5226584 (diff)
downloadports-4e049717137aa486b6b860ba779bec448bc9d50e.tar.gz
ports-4e049717137aa486b6b860ba779bec448bc9d50e.zip
Notes
Diffstat (limited to 'security/softhsm2/Makefile')
-rw-r--r--security/softhsm2/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index 81b379ee7320..8ab060c56de5 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= softhsm
-PORTVERSION= 2.2.0
-PORTREVISION= 1
+PORTVERSION= 2.3.0
CATEGORIES= security
MASTER_SITES= http://dist.opendnssec.org/source/ \
http://dist.opendnssec.org/source/testing/
@@ -13,18 +12,21 @@ MAINTAINER= jaap@NLnetLabs.nl
COMMENT= Software implementation of a Hardware Security Module (HSM)
LICENSE= BSD2CLAUSE
-
-LIB_DEPENDS= libsqlite3.so:databases/sqlite3
+LICENSE_FILE= ${WRKSRC}/LICENSE
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-sqlite3=${LOCALBASE} --localstatedir="${PREFIX}/var"
+CONFIGURE_ARGS= --localstatedir="${PREFIX}/var"
INSTALL_TARGET= install-strip
-USES= libtool sqlite
+USES= libtool ssl
CONFLICTS= softhsm-1.*
USE_LDCONFIG= yes
+OPTIONS_DEFINE= SQLITE
+OPTIONS_SUB= yes
+SQLITE_DESC= Build with object store backend DB support (SQLITE3)
+
OPTIONS_SINGLE= CRYP
OPTIONS_SINGLE_CRYP= CRYP_OPEN CRYP_BOTAN
@@ -33,9 +35,12 @@ CRYP_BOTAN_DESC= Build with Botan crypto library
OPTIONS_DEFAULT= CRYP_OPEN
+SQLITE_CONFIGURE_WITH= sqlite3=${LOCALBASE} objectstore-backend-db
+SQLITE_USES= sqlite
+
CRYP_BOTAN_CONFIGURE_ON= --with-crypto-backend=botan
CRYP_BOTAN_LIB_DEPENDS= libbotan-1.10.so:security/botan110
-CRYP_OPEN_USES= ssl
+
CRYP_OPEN_CONFIGURE_ON= --with-crypto-backend=openssl
.include <bsd.port.options.mk>
@@ -44,4 +49,8 @@ CRYP_OPEN_CONFIGURE_ON= --with-crypto-backend=openssl
CONFIGURE_ARGS+= --disable-gost
.endif
+.if ${SSL_DEFAULT:Mopenssl-devel}
+CONFIGURE_ARGS+= --disable-gost
+.endif
+
.include <bsd.port.mk>