aboutsummaryrefslogtreecommitdiff
path: root/security/softhsm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-25 10:31:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-25 10:31:40 +0000
commitbd57460c3924be25ad437a83415955c422a223a4 (patch)
treeeb879f95271bc1ec7302e74b822549c6fcc14c3b /security/softhsm
parentcefb42bb59dff64984ffae16ad9c632e7e389e40 (diff)
Notes
Diffstat (limited to 'security/softhsm')
-rw-r--r--security/softhsm/Makefile36
-rw-r--r--security/softhsm/distinfo3
-rw-r--r--security/softhsm/pkg-descr7
3 files changed, 46 insertions, 0 deletions
diff --git a/security/softhsm/Makefile b/security/softhsm/Makefile
new file mode 100644
index 000000000000..4b18a287a16f
--- /dev/null
+++ b/security/softhsm/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: softhsm
+# Date created: 15 December 2009
+# Whom: Jaap Akkerhuis <jaap@NLnetLabs.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= softhsm
+PORTVERSION= 1.1.2
+CATEGORIES= security
+MASTER_SITES= http://www.opendnssec.org/files/source/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jaap@NLnetLabs.nl
+COMMENT= A software implementation of a Hardware Security Module (HSM)
+
+LIB_DEPENDS= botan:${PORTSDIR}/security/botan
+LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
+
+GNU_CONFIGURE= yes
+
+USE_LDCONFIG= yes
+
+MAN1= softhsm.1 softhsm-keyconv.1
+MAN5= softhsm.conf.5
+
+PLIST_FILES= bin/softhsm \
+ bin/softhsm-keyconv \
+ lib/libsofthsm.a \
+ lib/libsofthsm.la \
+ lib/libsofthsm.so \
+ lib/libsofthsm.so.1 \
+ etc/softhsm.conf \
+ etc/softhsm.conf.sample
+
+.include <bsd.port.mk>
diff --git a/security/softhsm/distinfo b/security/softhsm/distinfo
new file mode 100644
index 000000000000..dd4d902d1aa8
--- /dev/null
+++ b/security/softhsm/distinfo
@@ -0,0 +1,3 @@
+MD5 (softhsm-1.1.2.tar.gz) = aff7520487e16dc3fdf245f8074cce49
+SHA256 (softhsm-1.1.2.tar.gz) = 43c38a45dc5103a351593c27b0aead34290586c7c1db0ba53007f418d1cc423d
+SIZE (softhsm-1.1.2.tar.gz) = 403391
diff --git a/security/softhsm/pkg-descr b/security/softhsm/pkg-descr
new file mode 100644
index 000000000000..2a6647d36acb
--- /dev/null
+++ b/security/softhsm/pkg-descr
@@ -0,0 +1,7 @@
+SoftHSM is an implementation of a cryptographic store accessible
+through a PKCS #11 interface. You can use it to explore PKCS #11
+without having a Hardware Security Module. It is being developed
+as a part of the OpenDNSSEC project. SoftHSM uses Botan for its
+cryptographic operations.
+
+WWW: http://www.opendnssec.org/