aboutsummaryrefslogtreecommitdiff
path: root/security/ssh-gui/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-12-16 14:11:03 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-12-16 14:11:03 +0000
commitfffae8bfc48e38e045c1114e2c1fdfba8f837f1c (patch)
treed8eb00676b668927f2eb777d17e61a3db3fe9893 /security/ssh-gui/Makefile
parentec15c81133fcdda2ef29232ddd013c965b7a60f2 (diff)
downloadports-fffae8bfc48e38e045c1114e2c1fdfba8f837f1c.tar.gz
ports-fffae8bfc48e38e045c1114e2c1fdfba8f837f1c.zip
Notes
Diffstat (limited to 'security/ssh-gui/Makefile')
-rw-r--r--security/ssh-gui/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/security/ssh-gui/Makefile b/security/ssh-gui/Makefile
new file mode 100644
index 000000000000..b0478b4cbbea
--- /dev/null
+++ b/security/ssh-gui/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ssh-gui
+# Date created: Fri Nov 30 22:14:14 BRST 2001
+# Whom: Hammurabi Mendes <hmendes_br@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssh-gui
+PORTVERSION= 0.7.1
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hmendes_br@yahoo.com
+
+RUN_DEPENDS= ssh:${PORTSDIR}/security/openssh
+
+USE_GTK= yes
+ALL_TARGET= ssh-gui
+
+DOC_FILES= README
+
+post-patch:
+ @${PERL} -pi.orig -e "s|^CC=.+$$||;s|(CFLAGS)=-Wall|\1\+=|; \
+ s|glib-config|${GLIB_CONFIG}|;s|gtk-config|${GTK_CONFIG}|" \
+ ${BUILD_WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>