aboutsummaryrefslogtreecommitdiff
path: root/security/ssh/Makefile
diff options
context:
space:
mode:
authorEivind Eklund <eivind@FreeBSD.org>1999-11-06 19:43:18 +0000
committerEivind Eklund <eivind@FreeBSD.org>1999-11-06 19:43:18 +0000
commit0447a5363773e0856eae269c88252078c638a781 (patch)
treebecb16be5093d41e21e38f407ddb55c59e5485cf /security/ssh/Makefile
parent11fe84cfc28fa1aadcc9fa80f57776edf4c05839 (diff)
downloadports-0447a5363773e0856eae269c88252078c638a781.tar.gz
ports-0447a5363773e0856eae269c88252078c638a781.zip
Notes
Diffstat (limited to 'security/ssh/Makefile')
-rw-r--r--security/ssh/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index 46ae6feeae7c..b637269eebea 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -143,4 +143,12 @@ LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
CONFIGURE_ARGS+= --with-socks="-L${PREFIX}/lib -lsocks5" --with-socks5
.endif
+# Include extra files if X11 is installed
+.if exists(${X11BASE}/lib/libX11.a)
+PLIST:= ${WRKDIR}/PLIST
+pre-install:
+ @${CAT} ${PKGDIR}/PLIST.X11 > ${PLIST}
+ @${CAT} ${PKGDIR}/PLIST >> ${PLIST}
+.endif
+
.include <bsd.port.post.mk>