aboutsummaryrefslogtreecommitdiff
path: root/security/ssh/Makefile
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-04-20 15:12:29 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-04-20 15:12:29 +0000
commit053520453dc374b6c02b15ad78efd7e0e52867f6 (patch)
tree9715c5e142788fa00b976d2c5a75b984e005be15 /security/ssh/Makefile
parent353346c8f2676860eb119c92298802aa94479b3a (diff)
downloadports-053520453dc374b6c02b15ad78efd7e0e52867f6.tar.gz
ports-053520453dc374b6c02b15ad78efd7e0e52867f6.zip
Notes
Diffstat (limited to 'security/ssh/Makefile')
-rw-r--r--security/ssh/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index e6ddaa99cf20..79e91a119e66 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -60,15 +60,13 @@ CONFIGURE_ARGS+= --with-secureid
CONFIGURE_ARGS+= --without-idea
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500023
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
MAKE_ENV+= GMPINCDIR="${LOCALBASE}/include" \
GMPLIBDIR="${LOCALBASE}/lib"
-.endif
-.if (${OSVERSION} >= 400016 && !defined(REALLY_WANT_SSH))
+.include <bsd.port.pre.mk>
+
+.if !defined(REALLY_WANT_SSH)
IGNORE= is now deprecated: OpenSSH is a superior version of SSH which has been included in the FreeBSD base system since 4.0-RELEASE. To override this warning set the REALLY_WANT_SSH environment variable and rebuild
.endif
@@ -110,7 +108,7 @@ CONFIGURE_ARGS+= --with-libwrap
# ssh-1.2.27-IPv6-1.5-patch.gz
# We still use WITH_INET6 here and try to support pre 4.0 machines with kame
# IPv6 stack
-.if ${OSVERSION} >= 400014 || ( ${OSVERSION} < 400014 && defined(WITH_INET6) )
+.if defined(WITH_INET6)
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6