aboutsummaryrefslogtreecommitdiff
path: root/security/ssh/files/patch-ac
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2002-06-30 03:57:57 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2002-06-30 03:57:57 +0000
commitd22f9c0925ec816f131349a9b2fa3999ad14108c (patch)
tree00308c13f160e3d97d0d390d056c7995e302fcbd /security/ssh/files/patch-ac
parent3a063823998c4033cd6adc312b8a7b688032688a (diff)
Notes
Diffstat (limited to 'security/ssh/files/patch-ac')
-rw-r--r--security/ssh/files/patch-ac39
1 files changed, 13 insertions, 26 deletions
diff --git a/security/ssh/files/patch-ac b/security/ssh/files/patch-ac
index 02fc5eae34fd..8926e9f150d9 100644
--- a/security/ssh/files/patch-ac
+++ b/security/ssh/files/patch-ac
@@ -1,27 +1,21 @@
---- Makefile.in.orig Mon Jul 3 10:07:39 2000
-+++ Makefile.in Fri Jun 21 17:50:07 2002
-@@ -307,13 +307,15 @@
+--- Makefile.in.orig Thu Jan 17 05:35:34 2002
++++ Makefile.in Sat Jun 29 20:37:40 2002
+@@ -307,11 +307,11 @@
SHELL = /bin/sh
-GMPDIR = gmp-2.0.2-ssh-2
--GMPLIBS = @ssh_gmp_ldadd_options@
++GMPDIR = $(PREFIX)
+ GMPLIBS = @ssh_gmp_ldadd_options@
-GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
-+# We have the same libgmp in the base system, so use it instead
-+GMPINCDIR ?= /usr/include
-+GMPLIBDIR ?= /usr/lib
-+GMPLIBS = -L$(GMPLIBDIR) -lgmp
-+GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
++GMPDEP =
-ZLIBDIR = zlib-1.0.4
+ZLIBDIR = /usr/lib
ZLIBDEP = $(ZLIBDIR)/libz.a
--ZLIBLIBS = @ssh_zlib_ldadd_options@
-+ZLIBLIBS = -lz
+ ZLIBLIBS = @ssh_zlib_ldadd_options@
- RSAREFDIR = rsaref2
- RSAREFSRCDIR = $(RSAREFDIR)/source
-@@ -418,7 +420,7 @@
+@@ -418,7 +418,7 @@
$(CC) -o rfc-pg rfc-pg.o
.c.o:
@@ -30,15 +24,8 @@
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
-rm -f sshd
-@@ -461,12 +463,12 @@
- sed "s#&PERL&#$(PERL)#" <$(srcdir)/make-ssh-known-hosts.pl >make-ssh-known-hosts
- chmod +x make-ssh-known-hosts
-
--GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
-+XXX_DONT_GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
- mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
--$(GMPDIR)/libgmp.a:
-+XXX_DONT_$(GMPDIR)/libgmp.a:
+@@ -466,7 +466,7 @@
+ $(GMPDIR)/libgmp.a:
cd $(GMPDIR); $(MAKE)
-$(ZLIBDEP):
@@ -46,7 +33,7 @@
-if test '!' -d $(ZLIBDIR); then \
mkdir $(ZLIBDIR); \
cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
-@@ -530,7 +532,7 @@
+@@ -530,7 +530,7 @@
# (otherwise it can only log in as the user it runs as, and must be
# bound to a non-privileged port). Also, password authentication may
# not be available if non-root and using shadow passwords.
@@ -55,12 +42,12 @@
-rm -f $(install_prefix)$(bindir)/ssh1.old
-chmod 755 $(install_prefix)$(bindir)/ssh1
-chmod 755 $(install_prefix)$(bindir)/ssh
-@@ -756,7 +758,7 @@
+@@ -756,7 +756,7 @@
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
depend:
- $(MAKEDEP) -I$(srcdir) -I. -I$(GMPDIR) -I$(ZLIBDIR) $(DEFS) $(SRCS)
-+ $(MAKEDEP) -I$(srcdir) -I. -I$(GMPINCDIR) $(DEFS) $(SRCS)
++ $(MAKEDEP) -I$(srcdir) -I. $(DEFS) $(SRCS)
tags:
-rm -f TAGS