aboutsummaryrefslogtreecommitdiff
path: root/security/ssh2/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-09-02 03:56:57 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-09-02 03:56:57 +0000
commitba8c80d1865153abfec7d00612976a30d9d5669e (patch)
tree41446f449d5ad32bcd08c82e7c6fb045f3392b89 /security/ssh2/Makefile
parentd64f2d8866444e6a40b10547fe44be7d69253a80 (diff)
downloadports-ba8c80d1865153abfec7d00612976a30d9d5669e.tar.gz
ports-ba8c80d1865153abfec7d00612976a30d9d5669e.zip
Notes
Diffstat (limited to 'security/ssh2/Makefile')
-rw-r--r--security/ssh2/Makefile66
1 files changed, 12 insertions, 54 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 5a7403803a5a..002bf70252e9 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -6,16 +6,12 @@
#
PORTNAME= ssh2
-PORTVERSION= 2.1.0p2
+PORTVERSION= 2.3.0
CATEGORIES= security
-MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/ \
+MASTER_SITES= ftp://ftp.ssh.com/pub/ssh/ \
ftp://sunsite.unc.edu/pub/packages/security/ssh/ \
ftp://ftp.kyoto.wide.ad.jp/pub/security/ssh/
-DISTNAME= ssh-secure-shell-2.1.0-noncommercial
-
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ssh-2.1.0-patch1
-PATCH_DIST_STRIP= -p1
+DISTNAME= ssh-${PORTVERSION}
MAINTAINER= issei@jp.FreeBSD.org
@@ -23,34 +19,16 @@ RESTRICTED= "Crypto; export-controlled"
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --enable-debug
+CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --disable-compiler-optimizations
#Uncomment if all your users are in their own group and their homedir
#is writeable by that group. Beware the security implications!
#CONFIGURE_ARGS+= --enable-group-writeability
.include <bsd.port.pre.mk>
-# Don't support for ssh1 client backward compatibility
-#WITHOUT_SSH1= yes
# Include tcp_wrappers support (automaticlly YES if /usr/include/tcpd.h exists)
#WITH_TCPWRAP= yes
-# Warning: untested!
-# Include support for the TIS authentication server
-#WITH_TIS= yes
-# Include support for the SecureID card
-#WITH_SECUREID= yes
-
-.if ${OSVERSION} < 400016 && !defined(WITHOUT_SSH1)
-BUILD_DEPENDS+= ssh1:${PORTSDIR}/security/ssh
-RUN_DEPENDS+= ssh1:${PORTSDIR}/security/ssh
-.endif
-.if defined(WITH_SECUREID)
-CONFIGURE_ARGS+= --with-secureid
-.endif
-.if defined(WITH_TIS)
-CONFIGURE_ARGS+= --with-tis
-.endif
.if exists(/usr/include/tcpd.h) && !defined(WITHOUT_TCPWRAP)
CONFIGURE_ARGS+= --with-libwrap
.elif defined(WITH_TCPWRAP)
@@ -58,38 +36,18 @@ CONFIGURE_ARGS+= --with-libwrap="-L ${PREFIX}/lib -lwrap"
LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.endif
-MAN1= ssh-add2.1 ssh-agent2.1 scp2.1 sftp2.1 sshregex.1 ssh-probe2.1 \
- ssh-dummy-shell.1 ssh-pubkeymgr.1 ssh2.1 ssh-keygen2.1
-MAN8= sshd2.8
-
-MLINKS= scp2.1 scp.1 \
- sftp2.1 sftp.1 \
- ssh-add2.1 ssh-add.1 \
- ssh-agent2.1 ssh-agent.1 \
- ssh-keygen2.1 ssh-keygen.1 \
- ssh-probe2.1 ssh-probe.1 \
- ssh2.1 ssh.1 \
- sshd2.8 sshd.8
+MAN1= scp.1 sftp.1 scp2.1 sftp2.1 sshregex.1 ssh-probe2.1 ssh-dummy-shell.1 \
+ ssh-pubkeymgr.1 ssh2.1 ssh-chrootmgr.1 ssh-agent.1 ssh-keygen.1 \
+ ssh-add.1 ssh-add2.1 ssh-agent2.1 ssh-keygen2.1
+MAN5= ssh2_config.5 sshd2_config.5
+MAN8= sshd.8 sshd2.8
-PORTDOCS= BUG.REPORT CHANGES FAQ INSTALL LICENSING README \
+PORTDOCS= BUG.REPORT CHANGES FAQ INSTALL LICENSE README \
SSH2.QUICKSTART
-.if ${OSVERSION} >= 400016 || defined(WITHOUT_SSH1)
-PLIST= ${PKGDIR}/PLIST.ssh2_only
-.endif
-
-.if exists(/usr/sbin/sshd)
-post-patch:
- @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/use-base-openssh.diff
-.endif
post-install:
-.if ${OSVERSION} < 400016 && !defined(WITHOUT_SSH1)
-.for i in ssh ssh-keygen ssh-add ssh-agent scp
- ${MV} -f ${PREFIX}/man/man1/${i}.1${MAN_SUFX} ${PREFIX}/man/man1/${i}.old.1${MAN_SUFX}
-.endfor
- ${MV} -f ${PREFIX}/man/man8/sshd.8${MAN_SUFX} ${PREFIX}/man/man8/sshd.old.8${MAN_SUFX}
-.endif
-#
+ ${RM} ${PREFIX}/man/man1/ssh.1
+ ${RM} ${PREFIX}/man/man1/ssh-probe.1
.if !defined(NOPORTDOCS)
-${MKDIR} ${PREFIX}/share/doc/ssh2
.for i in ${PORTDOCS}