aboutsummaryrefslogtreecommitdiff
path: root/security/ssh2
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-03-11 12:58:43 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-03-11 12:58:43 +0000
commit57f06be82e9b894c0443919fc5ef3ea2903742bd (patch)
tree03190ccd04f202ce406f3f1181072e07b3f2a148 /security/ssh2
parent763a221a872f990bebf9c42101f80652ac1bfd27 (diff)
downloadports-57f06be82e9b894c0443919fc5ef3ea2903742bd.tar.gz
ports-57f06be82e9b894c0443919fc5ef3ea2903742bd.zip
Notes
Diffstat (limited to 'security/ssh2')
-rw-r--r--security/ssh2/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index fbad42290535..13bc11c98b9c 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -30,6 +30,8 @@ CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --enable-debug
#is writeable by that group. Beware the security implications!
#CONFIGURE_ARGS+= --enable-group-writeability
+.include <bsd.port.pre.mk>
+
# Include support for ssh1 client backward compatibility
USE_SSH1?= YES
# Include tcp_wrappers support (automaticlly YES if /usr/include/tcpd.h exists)
@@ -40,10 +42,11 @@ USE_TIS?= NO
# Include support for the SecureID card
USE_SECUREID?= NO
-.if defined(USE_SSH1) && ${USE_SSH1} == YES
+.if ${OSVERSION} < 400016 && defined(USE_SSH1) && ${USE_SSH1} == YES
BUILD_DEPENDS+= ssh1:${PORTSDIR}/security/ssh
RUN_DEPENDS+= ssh1:${PORTSDIR}/security/ssh
.endif
+
.if defined(USE_SECUREID) && ${USE_SECUREID} == YES
CONFIGURE_ARGS+= --with-secureid
.endif
@@ -76,6 +79,11 @@ PORTDOCS= CHANGES LICENSING README
PLIST= ${PKGDIR}/PLIST.ssh2_only
.endif
+.if exists(/usr/sbin/sshd)
+post-patch:
+ @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/use-base-openssh.diff
+.endif
+
post-install:
.if defined(USE_SSH1) && ${USE_SSH1} == YES
.for i in ssh ssh-keygen ssh-add ssh-agent scp
@@ -98,4 +106,4 @@ post-install:
${CHMOD} 751 ${PREFIX}/etc/rc.d/sshd.sh; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>