aboutsummaryrefslogtreecommitdiff
path: root/security/ssh2
diff options
context:
space:
mode:
authorMarius Strobl <marius@FreeBSD.org>2006-03-04 17:36:07 +0000
committerMarius Strobl <marius@FreeBSD.org>2006-03-04 17:36:07 +0000
commit9cb5d6c6e1f5de91cc079b866eaee90e6cec263c (patch)
tree7bfc3de5a5a555742a771abe01b74ad212fa06ba /security/ssh2
parent888793f6ac07c6b6b34384a5b49e83b007c9f5d9 (diff)
downloadports-9cb5d6c6e1f5de91cc079b866eaee90e6cec263c.tar.gz
ports-9cb5d6c6e1f5de91cc079b866eaee90e6cec263c.zip
Notes
Diffstat (limited to 'security/ssh2')
-rw-r--r--security/ssh2/Makefile2
-rw-r--r--security/ssh2/files/patch-lib::sshfilexfer::sshfilexfers.c21
2 files changed, 22 insertions, 1 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index e4a27d82f7a5..ba2483ccee49 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ssh2
PORTVERSION= 3.2.9.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security ipv6
# The list of official mirror sites is at:
# http://www.ssh.com/support/downloads/secureshellserver/non-commercial.html
diff --git a/security/ssh2/files/patch-lib::sshfilexfer::sshfilexfers.c b/security/ssh2/files/patch-lib::sshfilexfer::sshfilexfers.c
new file mode 100644
index 000000000000..cb6133c7bebf
--- /dev/null
+++ b/security/ssh2/files/patch-lib::sshfilexfer::sshfilexfers.c
@@ -0,0 +1,21 @@
+--- lib/sshfilexfer/sshfilexfers.c.orig 2003-12-03 15:17:22.000000000 +0200
++++ lib/sshfilexfer/sshfilexfers.c 2006-02-22 10:44:25.000000000 +0200
+@@ -5,7 +5,7 @@
+ Authors: Tatu Ylonen <ylo@ssh.com>
+ Sami Lehtinen <sjl@ssh.com>
+
+- Copyright (c) 1998-2001 SSH Communications Security Corp, Finland
++ Copyright (c) 1998-2001, 2006 SSH Communications Security Corp, Finland
+ All rights reserved
+
+ Generic file transfer module, server side.
+@@ -115,7 +115,8 @@
+ if (server->log_facility >= 0) \
+ { \
+ char *msg = ssh_debug_format varcall; \
+- ssh_log_event(det_fac(category, server->log_facility), severity, msg); \
++ ssh_log_event(det_fac(category, server->log_facility), severity, \
++ "%s", msg); \
+ ssh_xfree(msg); \
+ } \
+ } while (0)