aboutsummaryrefslogtreecommitdiff
path: root/security/ssh_askpass_gtk2
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2010-02-06 18:02:40 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2010-02-06 18:02:40 +0000
commita7d02d3d3261557172f635f6c1e38df51fa81261 (patch)
tree07b3eabff33ffeb4c4ce981d12449c27c9f00002 /security/ssh_askpass_gtk2
parent3a2e6eed88075dc032058e987d55092abb121d74 (diff)
downloadports-a7d02d3d3261557172f635f6c1e38df51fa81261.tar.gz
ports-a7d02d3d3261557172f635f6c1e38df51fa81261.zip
Notes
Diffstat (limited to 'security/ssh_askpass_gtk2')
-rw-r--r--security/ssh_askpass_gtk2/Makefile2
-rw-r--r--security/ssh_askpass_gtk2/files/patch-ssh_askpass_fullscreen.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/security/ssh_askpass_gtk2/Makefile b/security/ssh_askpass_gtk2/Makefile
index 7760d2a745a5..b01cdfd08ea3 100644
--- a/security/ssh_askpass_gtk2/Makefile
+++ b/security/ssh_askpass_gtk2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ssh_askpass_gtk2
PORTVERSION= 0.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= http://www.cgabriel.org/download/ssh-askpass-fullscreen/
DISTNAME= ssh-askpass-fullscreen-${PORTVERSION}
diff --git a/security/ssh_askpass_gtk2/files/patch-ssh_askpass_fullscreen.c b/security/ssh_askpass_gtk2/files/patch-ssh_askpass_fullscreen.c
new file mode 100644
index 000000000000..1fdbf1878602
--- /dev/null
+++ b/security/ssh_askpass_gtk2/files/patch-ssh_askpass_fullscreen.c
@@ -0,0 +1,20 @@
+--- ssh-askpass-fullscreen.c.orig 2006-01-16 04:49:38.000000000 -0800
++++ ssh-askpass-fullscreen.c 2010-02-04 22:30:32.000000000 -0800
+@@ -44,7 +44,7 @@
+ #include <gtk/gtk.h>
+
+ /* XPM */
+-static char *ocean_stripes[] = {
++static const char *ocean_stripes[] = {
+ /* columns rows colors chars-per-pixel */
+ "64 64 3 1",
+ " c #A0A9C1",
+@@ -247,7 +247,7 @@
+ GdkColor color;
+ gchar *str;
+ GdkGrabStatus status;
+- int grab_tries;
++ int grab_tries = 0;
+ const char *failed;
+
+ grab_server = (getenv("GNOME_SSH_ASKPASS_GRAB_SERVER") != NULL);