aboutsummaryrefslogtreecommitdiff
path: root/security/sshguard
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-19 13:04:29 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-19 13:04:29 +0000
commit9c77b85cfae1bb5f61b578f659d854315d827f54 (patch)
treee4b0bd2e8728b3bb1f07ca572095f5402758bdd9 /security/sshguard
parent2eee1541a8aef90097edd978d31172a7b9cd3054 (diff)
downloadports-9c77b85cfae1bb5f61b578f659d854315d827f54.tar.gz
ports-9c77b85cfae1bb5f61b578f659d854315d827f54.zip
Notes
Diffstat (limited to 'security/sshguard')
-rw-r--r--security/sshguard/Makefile2
-rw-r--r--security/sshguard/files/patch-src_sshguard__logsuck.c36
2 files changed, 37 insertions, 1 deletions
diff --git a/security/sshguard/Makefile b/security/sshguard/Makefile
index 4a348790b4dd..7d8e6471cb60 100644
--- a/security/sshguard/Makefile
+++ b/security/sshguard/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sshguard
PORTVERSION= 1.6.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/sshguard/sshguard/${PORTVERSION}
diff --git a/security/sshguard/files/patch-src_sshguard__logsuck.c b/security/sshguard/files/patch-src_sshguard__logsuck.c
new file mode 100644
index 000000000000..58d086caf82c
--- /dev/null
+++ b/security/sshguard/files/patch-src_sshguard__logsuck.c
@@ -0,0 +1,36 @@
+--- src/sshguard_logsuck.c.orig 2015-08-19 16:11:25 UTC
++++ src/sshguard_logsuck.c
+@@ -92,8 +92,6 @@ int logsuck_add_logsource(const char *re
+ return -1;
+ }
+
+- sshguard_log(LOG_DEBUG, "Adding '%s' to polled files.", filename);
+-
+ /* store filename */
+ strcpy(cursource.filename, filename);
+
+@@ -185,7 +183,6 @@ int logsuck_getline(char *restrict buf,
+ }
+ }
+ /* no data. Wait for something with exponential backoff, up to LOGSUCK_MAX_WAIT */
+- sshguard_log(LOG_DEBUG, "Sleeping %d ms before next poll.", sleep_interval);
+ usleep(sleep_interval * 1000);
+ /* update sleep interval for next call */
+ if (sleep_interval < MAX_LOGPOLL_INTERVAL) {
+@@ -274,7 +271,6 @@ static int refresh_files() {
+ ++numchanged;
+ if (! myentry->active) {
+ /* entry was inactive, now available. Resume it */
+- sshguard_log(LOG_NOTICE, "Source '%s' reappeared. Reloading.", myentry->filename);
+ } else {
+ /* rotated (ie myentry->current_serial_number != fileinfo.st_ino) */
+ sshguard_log(LOG_NOTICE, "Reloading rotated file %s.", myentry->filename);
+@@ -285,8 +281,6 @@ static int refresh_files() {
+ /* descriptor and source ready! */
+ }
+ list_iterator_stop(& sources_list);
+-
+- sshguard_log(LOG_INFO, "Refreshing sources showed %u changes.", numchanged);
+ return 0;
+ }
+