aboutsummaryrefslogtreecommitdiff
path: root/security/sslscan
diff options
context:
space:
mode:
authorGavin Atkinson <gavin@FreeBSD.org>2018-08-15 21:26:19 +0000
committerGavin Atkinson <gavin@FreeBSD.org>2018-08-15 21:26:19 +0000
commitf82246e22389339af203649801f09244be5a24e2 (patch)
treeea66f9cd754261b9b99cd49d7a92fe8765f28183 /security/sslscan
parent2fcbc66eb827b4ae098f688e9ca8f4e5fb3c3a69 (diff)
downloadports-f82246e22389339af203649801f09244be5a24e2.tar.gz
ports-f82246e22389339af203649801f09244be5a24e2.zip
Upgrade security/sslscan to just past the 1.11.11 release, pulling in
a couple of bug fixes from upstream that have not yet made it into a release. Approved by: zeising
Notes
Notes: svn path=/head/; revision=477291
Diffstat (limited to 'security/sslscan')
-rw-r--r--security/sslscan/Makefile4
-rw-r--r--security/sslscan/distinfo6
-rw-r--r--security/sslscan/files/patch-Makefile16
-rw-r--r--security/sslscan/files/patch-sslscan.c12
-rw-r--r--security/sslscan/pkg-descr2
5 files changed, 22 insertions, 18 deletions
diff --git a/security/sslscan/Makefile b/security/sslscan/Makefile
index 89c14339ffa6..9a8f51f23f9c 100644
--- a/security/sslscan/Makefile
+++ b/security/sslscan/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sslscan
-PORTVERSION= 1.11.10
-DISTVERSIONSUFFIX= -${GH_ACCOUNT}
+PORTVERSION= 1.11.11
CATEGORIES= security
MAINTAINER= gavin@FreeBSD.org
@@ -18,6 +17,7 @@ UNSAFESSL_DESC= Use openssl-unsafe as libssl provider (SSLv2 etc.)
USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= rbsec
+GH_TAGNAME= 96ad4ff
UNSAFESSL_USES_OFF= ssl
UNSAFESSL_BUILD_DEPENDS= ${LOCALBASE}/openssl-unsafe/lib/libssl.so:security/openssl-unsafe
diff --git a/security/sslscan/distinfo b/security/sslscan/distinfo
index 3c0eb896bb9a..a90ffdd53ff2 100644
--- a/security/sslscan/distinfo
+++ b/security/sslscan/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494430653
-SHA256 (rbsec-sslscan-1.11.10-rbsec_GH0.tar.gz) = fbb26fdbf2cf5b2f3f8c88782721b7875f206552cf83201981411e0af9521204
-SIZE (rbsec-sslscan-1.11.10-rbsec_GH0.tar.gz) = 52108
+TIMESTAMP = 1534266511
+SHA256 (rbsec-sslscan-1.11.11-96ad4ff_GH0.tar.gz) = 15aafcb24c06f01edce1bd317f0b6b5a6cbe32db8883b586c3644c072394f4d2
+SIZE (rbsec-sslscan-1.11.11-96ad4ff_GH0.tar.gz) = 56273
diff --git a/security/sslscan/files/patch-Makefile b/security/sslscan/files/patch-Makefile
index 93f03df1b6d6..917527be75b5 100644
--- a/security/sslscan/files/patch-Makefile
+++ b/security/sslscan/files/patch-Makefile
@@ -1,27 +1,23 @@
---- Makefile.orig 2016-11-06 13:27:11 UTC
+--- Makefile.orig 2018-06-15 17:47:17 UTC
+++ Makefile
-@@ -3,7 +3,7 @@ ifndef CC
- CC=gcc
- endif
+@@ -1,6 +1,6 @@
+ # set gcc as default if CC is not set
-GIT_VERSION = $(shell git describe --tags --always --dirty=-wip)
+#GIT_VERSION = $(shell git describe --tags --always --dirty=-wip)
# Ugly hack to get version if git isn't installed
ifeq ($(GIT_VERSION),)
-@@ -14,9 +14,9 @@ endif
- OS := $(shell uname)
+@@ -25,7 +25,7 @@ endif
SRCS = sslscan.c
--PREFIX = /usr
-+#PREFIX = /usr
BINDIR = $(PREFIX)/bin
-MANDIR = $(PREFIX)/share/man
+MANDIR = $(PREFIX)/man
MAN1DIR = $(MANDIR)/man1
- WARNINGS = -Wall -Wformat=2
-@@ -70,6 +70,9 @@ ifeq ($(OS), Darwin)
+ WARNINGS = -Wall -Wformat=2 -Wformat-security
+@@ -101,6 +101,9 @@ ifeq ($(OS), Darwin)
install sslscan $(DESTDIR)$(BINDIR)/sslscan;
install -d $(DESTDIR)$(MAN1DIR)/;
install sslscan.1 $(DESTDIR)$(MAN1DIR)/sslscan.1;
diff --git a/security/sslscan/files/patch-sslscan.c b/security/sslscan/files/patch-sslscan.c
index 00bf0aa861a0..1ac573b1f0fd 100644
--- a/security/sslscan/files/patch-sslscan.c
+++ b/security/sslscan/files/patch-sslscan.c
@@ -1,6 +1,14 @@
---- sslscan.c.orig 2016-11-06 13:27:11 UTC
+--- sslscan.c.orig 2018-06-15 17:47:17 UTC
+++ sslscan.c
-@@ -829,7 +829,7 @@ int testCompression(struct sslCheckOptio
+@@ -112,6 +112,7 @@
+
+ #if defined(__FreeBSD__) || defined(__OpenBSD__)
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #endif
+
+ #include "sslscan.h"
+@@ -896,7 +897,7 @@ int testCompression(struct sslCheckOptions *options, c
#endif
{
printf("%sOpenSSL version does not support compression%s\n", COL_RED, RESET);
diff --git a/security/sslscan/pkg-descr b/security/sslscan/pkg-descr
index 458322a24ef2..433c5469c966 100644
--- a/security/sslscan/pkg-descr
+++ b/security/sslscan/pkg-descr
@@ -4,4 +4,4 @@ prefered ciphers, which SSL protocols are supported and returns the
SSL certificate. Client certificates and private key can be configured
and output is to text / XML.
-WWW: https://sourceforge.net/projects/sslscan/
+WWW: https://github.com/rbsec/sslscan/