aboutsummaryrefslogtreecommitdiff
path: root/security/sslwrap/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-16 05:34:33 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-16 05:34:33 +0000
commit443cc9ea79c6fe8c0ccb29e53c3e71e9ec69ef39 (patch)
tree6cd6c99a0e209b7d68b53cf8b95627c00530fc50 /security/sslwrap/Makefile
parent902e992ec1437129c2e212c75968cbf90a44517b (diff)
downloadports-443cc9ea79c6fe8c0ccb29e53c3e71e9ec69ef39.tar.gz
ports-443cc9ea79c6fe8c0ccb29e53c3e71e9ec69ef39.zip
Notes
Diffstat (limited to 'security/sslwrap/Makefile')
-rw-r--r--security/sslwrap/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/security/sslwrap/Makefile b/security/sslwrap/Makefile
index 2008b7e1e814..7be7c15f5666 100644
--- a/security/sslwrap/Makefile
+++ b/security/sslwrap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sslwrap
PORTVERSION= 2.0.6
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.quiltaholic.com/rickk/sslwrap/
DISTNAME= ${PORTNAME}
@@ -19,14 +20,13 @@ USE_REINPLACE= YES
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-patch:
- ${REINPLACE_CMD} -e 's/SSL_OP_NON_EXPORT_FIRST/SSL_OP_CIPHER_SERVER_PREFERENCE/g' ${WRKSRC}/s_server.c
+ ${REINPLACE_CMD} -e \
+ 's/SSL_OP_NON_EXPORT_FIRST/SSL_OP_CIPHER_SERVER_PREFERENCE/g' \
+ ${WRKSRC}/s_server.c
+ ${REINPLACE_CMD} -e \
+ 's,%%OPENSSL%%,openssl/,g' \
+ ${WRKSRC}/s_server.c ${WRKSRC}/s_cb.c ${WRKSRC}/apps.h ${WRKSRC}/s_socket.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sslwrap ${PREFIX}/bin/sslwrap
@@ -36,4 +36,4 @@ do-install:
${PREFIX}/share/doc/sslwrap
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>