aboutsummaryrefslogtreecommitdiff
path: root/security/sssd/files/patch-Makefile.am
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-10-15 02:13:20 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-10-15 02:13:20 +0000
commit2e567b748dfc85a433ba5880fe1d9394453600c8 (patch)
tree445605ec8ea8fe34e781283d0abcf0e7fbbdbb41 /security/sssd/files/patch-Makefile.am
parenta62c6c03949509b0df9a8548802d2e2894e541eb (diff)
downloadports-2e567b748dfc85a433ba5880fe1d9394453600c8.tar.gz
ports-2e567b748dfc85a433ba5880fe1d9394453600c8.zip
New port: security/sssd
sssd integrates the functionality of pam_krb5 and pam_ldap/nss_ldap with caching and additional features. This project provides a set of daemons to manage access to remote directories and authentication mechanisms, it provides an NSS and PAM interface toward the system and a pluggable backend system to connect to multiple different account sources. It is also the basis to provide client auditing and policy services for projects like FreeIPA. sssd also features caching, which can allow for offline use to assist laptop users. WWW: https://fedorahosted.org/sssd/ PR: ports/161555 Submitted by: Andrew Elble <aweits@rit.edu>
Notes
Notes: svn path=/head/; revision=283553
Diffstat (limited to 'security/sssd/files/patch-Makefile.am')
-rw-r--r--security/sssd/files/patch-Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/security/sssd/files/patch-Makefile.am b/security/sssd/files/patch-Makefile.am
new file mode 100644
index 000000000000..09c82b62d726
--- /dev/null
+++ b/security/sssd/files/patch-Makefile.am
@@ -0,0 +1,61 @@
+--- ./Makefile.am.orig 2011-08-29 11:39:05.000000000 -0400
++++ ./Makefile.am 2011-10-13 12:13:42.000000000 -0400
+@@ -33,7 +33,7 @@
+ systemdunitdir = @systemdunitdir@
+ logpath = @logpath@
+ pubconfpath = @pubconfpath@
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+
+ AM_CFLAGS =
+ if WANT_AUX_INFO
+@@ -753,21 +753,22 @@
+
+ noinst_PROGRAMS = pam_test_client
+ pam_test_client_SOURCES = src/sss_client/pam_test_client.c
+-pam_test_client_LDFLAGS = -lpam -lpam_misc
++pam_test_client_LDFLAGS = -lpam
+
+ ####################
+ # Client Libraries #
+ ####################
+
+-nsslib_LTLIBRARIES = libnss_sss.la
+-libnss_sss_la_SOURCES = \
++nsslib_LTLIBRARIES = nss_sss.la
++nss_sss_la_SOURCES = \
+ src/sss_client/common.c \
++ src/sss_client/bsdnss.c \
+ src/sss_client/nss_passwd.c \
+ src/sss_client/nss_group.c \
+ src/sss_client/nss_netgroup.c \
+ src/sss_client/sss_cli.h \
+ src/sss_client/nss_compat.h
+-libnss_sss_la_LDFLAGS = \
++nss_sss_la_LDFLAGS = \
+ -module \
+ -version-info 2:0:0 \
+ -Wl,--version-script,$(srcdir)/src/sss_client/sss_nss.exports
+@@ -780,6 +781,7 @@
+ src/sss_client/sss_pam_macros.h
+
+ pam_sss_la_LDFLAGS = \
++ -lintl \
+ -lpam \
+ -module \
+ -avoid-version \
+@@ -1122,10 +1124,10 @@
+ mkdir -p $(DESTDIR)$(initdir)
+ endif
+
+-install-data-hook:
+- rm $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2 \
+- $(DESTDIR)/$(nsslibdir)/libnss_sss.so
+- mv $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2.0.0 $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2
++notnotnotnotnotnotnotnotnotnotnotnotnotnotnotnotnotinstall-data-hook:
++ rm $(DESTDIR)/$(nsslibdir)/nss_sss.so.2 \
++ $(DESTDIR)/$(nsslibdir)/nss_sss.so
++ mv $(DESTDIR)/$(nsslibdir)/nss_sss.so.2.0.0 $(DESTDIR)/$(nsslibdir)/nss_sss.so.2
+
+ uninstall-hook:
+ if [ -f $(abs_builddir)/src/config/.files ]; then \