aboutsummaryrefslogtreecommitdiff
path: root/security/sst
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-31 10:37:43 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-31 10:37:43 +0000
commitdb71e5e6aadd2a32642786702f6acd489a481e44 (patch)
tree6404850843ab8fd43666c7e89fa75cc71d9050ca /security/sst
parent1d16e4d231851c3627b4d964cf9ed4b6e4d27294 (diff)
downloadports-db71e5e6aadd2a32642786702f6acd489a481e44.tar.gz
ports-db71e5e6aadd2a32642786702f6acd489a481e44.zip
Notes
Diffstat (limited to 'security/sst')
-rw-r--r--security/sst/Makefile24
-rw-r--r--security/sst/distinfo1
-rw-r--r--security/sst/files/Makefile13
-rw-r--r--security/sst/files/patch-sst.c24
-rw-r--r--security/sst/pkg-comment1
-rw-r--r--security/sst/pkg-descr23
-rw-r--r--security/sst/pkg-plist1
7 files changed, 87 insertions, 0 deletions
diff --git a/security/sst/Makefile b/security/sst/Makefile
new file mode 100644
index 000000000000..d23cbd3ec3fd
--- /dev/null
+++ b/security/sst/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sst
+# Date created: Nov 7, 2000
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sst
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://utcc.utoronto.ca/~pkern/stuff/sst/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= mi@aldan.algebra.com
+
+RUN_DEPENDS= nc:${PORTSDIR}/net/netcat
+
+USE_OPENSSL= YES
+MAN1= sst.1
+MANCOMPRESSED= maybe
+
+MAKEFILE= ${FILESDIR}/Makefile
+
+.include <bsd.port.mk>
diff --git a/security/sst/distinfo b/security/sst/distinfo
new file mode 100644
index 000000000000..1793af253680
--- /dev/null
+++ b/security/sst/distinfo
@@ -0,0 +1 @@
+MD5 (sst.tar.gz) = cb1a2290ab0554381c778d147bab4dd7
diff --git a/security/sst/files/Makefile b/security/sst/files/Makefile
new file mode 100644
index 000000000000..be39899e366f
--- /dev/null
+++ b/security/sst/files/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PROG=sst
+
+BINDIR=${PREFIX}/sbin
+MANDIR=${PREFIX}/man/man
+
+CFLAGS+= -DCONFDIR='"${OPENSSLDIR}"' -DCERTF='"certs/sst.pem"' \
+ -DNETCAT='"${PREFIX}/bin/nc"' -I${OPENSSLINC}
+
+LDADD+= -L${OPENSSLLIB} -lssl -lcrypto
+
+.include <bsd.prog.mk>
diff --git a/security/sst/files/patch-sst.c b/security/sst/files/patch-sst.c
new file mode 100644
index 000000000000..c42f282ca577
--- /dev/null
+++ b/security/sst/files/patch-sst.c
@@ -0,0 +1,24 @@
+--- sst.c Thu May 4 14:47:28 2000
++++ sst.c.new Sun Dec 31 04:49:43 2000
+@@ -609,8 +609,8 @@
+ SHOW_info1("client cert subject: %s", subj);
+ SHOW_info1("client cert issuer: %s", issu);
+
+- Free(subj);
+- Free(issu);
++ free(subj);
++ free(issu);
+
+ /*
+ * XXX ...
+@@ -699,8 +699,8 @@
+ SHOW_info1("server cert subject: %s", subj);
+ SHOW_info1("server cert issuer: %s", issu);
+
+- Free(subj);
+- Free(issu);
++ free(subj);
++ free(issu);
+
+ /*
+ * XXX ...
diff --git a/security/sst/pkg-comment b/security/sst/pkg-comment
new file mode 100644
index 000000000000..b6c7a8349800
--- /dev/null
+++ b/security/sst/pkg-comment
@@ -0,0 +1 @@
+A simple SSL tunneling tool (uses netcat)
diff --git a/security/sst/pkg-descr b/security/sst/pkg-descr
new file mode 100644
index 000000000000..0c5098ec45fb
--- /dev/null
+++ b/security/sst/pkg-descr
@@ -0,0 +1,23 @@
+Sst can be used to connect to SSL-encrypted network ser-
+vices or it can be used as an SSL front-end to network
+servers. Sst can be used interactively, or in an inetd
+setting, or it can be embedded inside other programs (eg.
+Amanda).
+
+
+One of the main goals of sst is to be as basic as possible
+so in most non-embedded cases sst uses netcat to setup the
+networking I/O. Sst uses a socketpair(2) pipe to stay in
+contact with its netcat child process. In this way sst
+only has to concern itself with file descriptors.
+
+In the embedded mode sst expects the parent program to set
+up the networking I/O and to provide the appropriate file
+descriptors. In embedded client mode ("-c"), clear data
+is read from (or written to) stdin (fildes 0) and SSL-
+encrypted data is read from (or written to) stdout (fildes
+1). In embedded server mode ("-s"), SSL-encrypted data is
+read from (or written to) stdin and clear data read from
+(or written to) stdout.
+
+WWW: http://utcc.utoronto.ca/~pkern/stuff/sst/
diff --git a/security/sst/pkg-plist b/security/sst/pkg-plist
new file mode 100644
index 000000000000..4fc5cfc4e3c8
--- /dev/null
+++ b/security/sst/pkg-plist
@@ -0,0 +1 @@
+sbin/sst