aboutsummaryrefslogtreecommitdiff
path: root/security/stegdetect
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-04 14:23:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-04 14:23:54 +0000
commit11a0f387a898bf639e5ad41243642ba13f2e36ab (patch)
tree69fd0028dfaa8d8efba0784807335f9db889055a /security/stegdetect
parentf387edc8e95675c6f26cbbcb223b8ddec80e0a18 (diff)
downloadports-11a0f387a898bf639e5ad41243642ba13f2e36ab.tar.gz
ports-11a0f387a898bf639e5ad41243642ba13f2e36ab.zip
Notes
Diffstat (limited to 'security/stegdetect')
-rw-r--r--security/stegdetect/Makefile18
-rw-r--r--security/stegdetect/files/patch-stegdetect.c8
-rw-r--r--security/stegdetect/pkg-descr12
3 files changed, 20 insertions, 18 deletions
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index 75ab0c01b42b..572b9b5651c0 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: stegdetect
-# Date created: Jul 19, 2001
-# Whom: Mark Pulford <mark@kyne.com.au>
+# Date created: Jul 19, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
#
# $FreeBSD$
#
@@ -33,17 +33,11 @@ CONFIGURE_ENV+= PATH_GTKCONFIG="${GTK_CONFIG}"
PLIST_SUB+= X11=""
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
post-patch:
- ${REINPLACE_CMD} 's;/usr/include/event;${LOCALBASE}/include;g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's;/usr/include/event;${LOCALBASE}/include;g' \
+ ${WRKSRC}/configure
.if defined(WITHOUT_X11)
- ${REINPLACE_CMD} 's/gtk-config//g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's/gtk-config//g' ${WRKSRC}/configure
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/stegdetect/files/patch-stegdetect.c b/security/stegdetect/files/patch-stegdetect.c
index effb4122aa0f..f9edc10e80eb 100644
--- a/security/stegdetect/files/patch-stegdetect.c
+++ b/security/stegdetect/files/patch-stegdetect.c
@@ -1,5 +1,13 @@
--- stegdetect.c.orig Sat Apr 15 00:14:05 2006
+++ stegdetect.c Sat Apr 15 00:14:40 2006
+@@ -78,7 +78,6 @@
+ float DCThist[257];
+ float scale = 1; /* Sensitivity scaling */
+
+-static int debug = 0;
+ static int quiet = 0;
+ static int ispositive = 0; /* Current images contain stego */
+ static char *transformname; /* Current transform name */
@@ -1227,7 +1227,7 @@
strlcat(outbuf, quality(tmp, stars), sizeof(outbuf));
flag = 1;
diff --git a/security/stegdetect/pkg-descr b/security/stegdetect/pkg-descr
index be14f6f0b232..b57c3d1ab4a2 100644
--- a/security/stegdetect/pkg-descr
+++ b/security/stegdetect/pkg-descr
@@ -3,11 +3,11 @@ in images. It is capable of detecting several different
steganographic methods to embed hidden information in JPEG images.
Currently, the detectable schemes are:
-* jsteg
-* jphide (unix and windows)
-* invisible secrets
-* outguess 01.3b
-* F5
-# appendX and camouflage
+ * jsteg
+ * jphide (unix and windows)
+ * invisible secrets
+ * outguess 01.3b
+ * F5
+ * appendX and camouflage
WWW: http://www.outguess.org/detection.php