aboutsummaryrefslogtreecommitdiff
path: root/security/stegdetect
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-29 01:56:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-29 01:56:32 +0000
commit5fb1a4c0bf987b83b0b0cc77d40ac2e8780f01d3 (patch)
treea3895b4f96b72b96a7b3fd5e028fda7366e698f5 /security/stegdetect
parentb6ce3f7d0d7986645ad6197104de4b2cce0772f3 (diff)
downloadports-5fb1a4c0bf987b83b0b0cc77d40ac2e8780f01d3.tar.gz
ports-5fb1a4c0bf987b83b0b0cc77d40ac2e8780f01d3.zip
Notes
Diffstat (limited to 'security/stegdetect')
-rw-r--r--security/stegdetect/Makefile8
-rw-r--r--security/stegdetect/files/patch-break_jsteg.c11
-rw-r--r--security/stegdetect/files/patch-common.c47
-rw-r--r--security/stegdetect/files/patch-stegdetect.c29
4 files changed, 88 insertions, 7 deletions
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index c0bd5055159c..d5ef8ec8e2cc 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -33,12 +33,6 @@ CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}"
PLIST_SUB+= X11=""
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-patch:
${REINPLACE_CMD} 's/$$(JPEGLIB)/$$(JPEGLIB) -lcrypto/' \
${WRKSRC}/Makefile.in
@@ -46,4 +40,4 @@ post-patch:
${REINPLACE_CMD} 's/gtk-config//g' ${WRKSRC}/configure
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/stegdetect/files/patch-break_jsteg.c b/security/stegdetect/files/patch-break_jsteg.c
new file mode 100644
index 000000000000..9a636fdacebe
--- /dev/null
+++ b/security/stegdetect/files/patch-break_jsteg.c
@@ -0,0 +1,11 @@
+--- break_jsteg.c Fri Dec 21 01:11:32 2001
++++ /tmp/break_jsteg.c.diff Wed Dec 29 03:32:38 2004
+@@ -162,7 +162,7 @@
+ jstegob->skip = bytes - sizeof(jstegob->coeff);
+
+ if (jsbits < max || off + jsbits > bits) {
+- warnx(__FUNCTION__": bad size in bits, %d", bits);
++ warnx("break_jsteg_prepare: bad size in bits, %d", bits);
+ return (NULL);
+ }
+
diff --git a/security/stegdetect/files/patch-common.c b/security/stegdetect/files/patch-common.c
new file mode 100644
index 000000000000..b49b0e7fe536
--- /dev/null
+++ b/security/stegdetect/files/patch-common.c
@@ -0,0 +1,47 @@
+--- common.c Tue Jan 22 19:25:38 2002
++++ common.c.diff Wed Dec 29 03:35:11 2004
+@@ -85,7 +85,7 @@
+
+ if (datasrc->bytes_in_buffer == 0) {
+ if (! (*datasrc->fill_input_buffer) (cinfo))
+- err(1, __FUNCTION__": fill_input");
++ err(1, "jpeg_getc: fill_input");
+ }
+ datasrc->bytes_in_buffer--;
+ return GETJOCTET(*datasrc->next_input_byte++);
+@@ -297,7 +297,7 @@
+
+ dcts = malloc(bits * sizeof (short));
+ if (dcts == NULL) {
+- warn(__FUNCTION__": malloc");
++ warn("prepare_all: malloc");
+ return (-1);
+ }
+
+@@ -362,7 +362,7 @@
+ if (pdcts != NULL) {
+ dcts = malloc(bits * sizeof (short));
+ if (dcts == NULL) {
+- warn(__FUNCTION__": malloc");
++ warn("prepare_normal: malloc");
+ return (-1);
+ }
+ }
+@@ -410,7 +410,7 @@
+ /* XXX - wasteful */
+ back[comp] = calloc(off, sizeof (char));
+ if (back[comp] == NULL) {
+- warn(__FUNCTION__": calloc");
++ warn("prepare_jphide: calloc");
+ goto err;
+ }
+ }
+@@ -418,7 +418,7 @@
+ if (pdcts != NULL) {
+ dcts = malloc(mbits * sizeof (short));
+ if (dcts == NULL) {
+- warn(__FUNCTION__": malloc");
++ warn("prepare_jphide: malloc");
+ goto err;
+ }
+ }
diff --git a/security/stegdetect/files/patch-stegdetect.c b/security/stegdetect/files/patch-stegdetect.c
new file mode 100644
index 000000000000..d5513215a78e
--- /dev/null
+++ b/security/stegdetect/files/patch-stegdetect.c
@@ -0,0 +1,29 @@
+--- stegdetect.c Sat Jan 26 23:51:16 2002
++++ /tmp/stegdetect.c.diff Wed Dec 29 03:32:38 2004
+@@ -1198,7 +1198,7 @@
+ flag = 1;
+ strlcat(outbuf, " f5(***)", sizeof(outbuf));
+
+- no_f5:
++ no_f5:;
+ }
+
+ if (scans & FLAG_DOINVIS) {
+@@ -1237,7 +1237,7 @@
+ strlcat(outbuf, tmp, sizeof(outbuf));
+ }
+
+- no_invisiblesecrets:
++ no_invisiblesecrets:;
+ }
+
+ if ((scans & FLAG_CHECKHDRS)) {
+@@ -1301,7 +1301,7 @@
+ }
+
+ free(dcts);
+- jsteg_error:
++ jsteg_error:;
+ }
+
+ if ((scans & FLAG_DOOUTGUESS) && prepare_normal(&dcts, &bits) != -1) {