aboutsummaryrefslogtreecommitdiff
path: root/security/steghide/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 17:35:49 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 17:35:49 +0000
commit22b385e041a6dd9ee93cad3fb3f0af10063415c9 (patch)
tree920319ef8f9c03148cc7943af98a4415c845d8e6 /security/steghide/Makefile
parentd89a76a99751a0cf45f91b4d135fbb9a31c33e80 (diff)
downloadports-22b385e041a6dd9ee93cad3fb3f0af10063415c9.tar.gz
ports-22b385e041a6dd9ee93cad3fb3f0af10063415c9.zip
Notes
Diffstat (limited to 'security/steghide/Makefile')
-rw-r--r--security/steghide/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index d3dea4986069..a2ec52ffef6f 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -32,5 +32,17 @@ post-patch:
${REINPLACE_CMD} -e 's|install-data-am\: install-docDATA||' \
${WRKSRC}/Makefile.in
.endif
+.for i in msg.h arg.h cvrstgfile.h error.h jpegjfifapp0.h
+ ${REINPLACE_CMD} -e 's/#include <string>//' ${WRKSRC}/src/${i}
+ ${REINPLACE_CMD} -e 's/string/std::string/g' ${WRKSRC}/src/${i}
+.endfor
+.for i in hash.cc bufmanag.cc wavfile.cc
+ ${REINPLACE_CMD} -e 's/string.h/string/' ${WRKSRC}/src/${i}
+.endfor
+.for i in jpeghufftable.h jpegbase.h jpegentropycoded.h jpegscan.h \
+ jpegframe.h bmpfile.h aufile.h jpegunusedseg.h
+ ${REINPLACE_CMD} -e 's/#include <vector>//' ${WRKSRC}/src/${i}
+ ${REINPLACE_CMD} -e 's/vector/std::vector/g' ${WRKSRC}/src/${i}
+.endfor
.include <bsd.port.mk>