aboutsummaryrefslogtreecommitdiff
path: root/security/stoken/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-08-12 12:39:58 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-08-12 12:39:58 +0000
commitc30d4d24d22454769c3dd6dff52385b6ca603c3d (patch)
tree8afee39fdb1223a96f415a0f1551b22ef90c1b06 /security/stoken/Makefile
parent7d2c34ff184296d25d5b12a584c194a690011407 (diff)
downloadports-c30d4d24d22454769c3dd6dff52385b6ca603c3d.tar.gz
ports-c30d4d24d22454769c3dd6dff52385b6ca603c3d.zip
Notes
Diffstat (limited to 'security/stoken/Makefile')
-rw-r--r--security/stoken/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/stoken/Makefile b/security/stoken/Makefile
new file mode 100644
index 000000000000..7b70a3cb0e14
--- /dev/null
+++ b/security/stoken/Makefile
@@ -0,0 +1,36 @@
+# Created by: Alex Samorukov <samm@os2.kiev.ua>
+# $FreeBSD$
+
+PORTNAME= stoken
+PORTVERSION= 0.6
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=stoken
+
+MAINTAINER= samm@os2.kiev.ua
+COMMENT= Software Token for UNIX compatible with RSA SecurID
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libtomcrypt.so:${PORTSDIR}/security/libtomcrypt
+
+OPTIONS_DEFINE= X11
+OPTIONS_SUB= yes
+
+X11_CONFIGURE_WITH= gtk
+X11_DESC= Build GUI token interface
+X11_USE= GNOME=gtk20
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+
+USE_LDCONFIG= yes
+USE_GNOME= libxml2
+USES= pkgconfig libtool
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>