aboutsummaryrefslogtreecommitdiff
path: root/security/strongswan
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2019-05-29 12:12:50 +0000
committerRenato Botelho <garga@FreeBSD.org>2019-05-29 12:12:50 +0000
commitd5a85043e3bae48b577d1f2412f10a021a4a2a17 (patch)
tree1b003177ed56abea1c1e91a860f9d98f4143ffb8 /security/strongswan
parentd68351d97d3e88d1eef0faa8b35222dd316cee0a (diff)
downloadports-d5a85043e3bae48b577d1f2412f10a021a4a2a17.tar.gz
ports-d5a85043e3bae48b577d1f2412f10a021a4a2a17.zip
Notes
Diffstat (limited to 'security/strongswan')
-rw-r--r--security/strongswan/Makefile3
-rw-r--r--security/strongswan/distinfo6
-rw-r--r--security/strongswan/files/patch-conf_Makefile.in10
3 files changed, 9 insertions, 10 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index 908c1b48a624..49a1c4ee2eb3 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= strongswan
-PORTVERSION= 5.7.2
-PORTREVISION= 2
+PORTVERSION= 5.8.0
CATEGORIES= security
MASTER_SITES= http://download.strongswan.org/ \
http://download2.strongswan.org/
diff --git a/security/strongswan/distinfo b/security/strongswan/distinfo
index 65df6fa590cf..173092bf446c 100644
--- a/security/strongswan/distinfo
+++ b/security/strongswan/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1545909109
-SHA256 (strongswan-5.7.2.tar.bz2) = 308e3ba76e2ce2da070e48fcebbe1fa923a27cc71e43bf63917e6f2a889ecc70
-SIZE (strongswan-5.7.2.tar.bz2) = 4997818
+TIMESTAMP = 1558966248
+SHA256 (strongswan-5.8.0.tar.bz2) = 15b1e10c7dd6253ab5d791fe9b9cb84624e24c118aecd9b90251b4e60daa0933
+SIZE (strongswan-5.8.0.tar.bz2) = 4516950
diff --git a/security/strongswan/files/patch-conf_Makefile.in b/security/strongswan/files/patch-conf_Makefile.in
index f7237e729f22..0d8969f38a06 100644
--- a/security/strongswan/files/patch-conf_Makefile.in
+++ b/security/strongswan/files/patch-conf_Makefile.in
@@ -1,21 +1,21 @@
---- conf/Makefile.in.orig 2018-12-27 09:46:13 UTC
+--- conf/Makefile.in.orig 2019-03-29 18:18:48 UTC
+++ conf/Makefile.in
@@ -899,15 +899,15 @@ install-data-local: $(plugins_install_src)
test -e "$(DESTDIR)${strongswanconfdir}" || $(INSTALL) -d "$(DESTDIR)$(strongswanconfdir)" || true
test -e "$(DESTDIR)${strongswanddir}" || $(INSTALL) -d "$(DESTDIR)$(strongswanddir)" || true
test -e "$(DESTDIR)${charonconfdir}" || $(INSTALL) -d "$(DESTDIR)$(charonconfdir)" || true
-- test -e "$(DESTDIR)$(strongswanconfdir)/strongswan.conf" || $(INSTALL) -m 644 $(srcdir)/strongswan.conf $(DESTDIR)$(strongswanconfdir)/strongswan.conf || true
-+ test -e "$(DESTDIR)$(strongswanconfdir)/strongswan.conf" || $(INSTALL) -m 644 $(srcdir)/strongswan.conf $(DESTDIR)$(strongswanconfdir)/strongswan.conf.sample || true
+- test -e "$(DESTDIR)$(strongswan_conf)" || $(INSTALL) -m 644 $(srcdir)/strongswan.conf $(DESTDIR)$(strongswan_conf) || true
++ test -e "$(DESTDIR)$(strongswan_conf)" || $(INSTALL) -m 644 $(srcdir)/strongswan.conf $(DESTDIR)$(strongswan_conf).sample || true
for f in $(options_install_src); do \
name=`basename $$f`; \
- test -f "$(DESTDIR)$(strongswanddir)/$$name" || $(INSTALL) -m 644 "$(srcdir)/$$f" "$(DESTDIR)$(strongswanddir)/$$name" || true; \
-+ test -f "$(DESTDIR)$(strongswanddir)/$$name" || $(INSTALL) -m 644 "$(srcdir)/$$f" "$(DESTDIR)$(strongswanddir)/$$name.sample" || true; \
++ test -f "$(DESTDIR)$(strongswanddir)/$$name" || $(INSTALL) -m 644 "$(srcdir)/$$f" "$(DESTDIR)$(strongswanddir)/$${name}.sample" || true; \
done
for f in $(plugins_install_src); do \
name=`basename $$f`; \
if test -f "$$f"; then dir=; else dir="$(srcdir)/"; fi; \
- test -f "$(DESTDIR)$(charonconfdir)/$$name" || $(INSTALL) -m 644 "$$dir$$f" "$(DESTDIR)$(charonconfdir)/$$name" || true; \
-+ test -f "$(DESTDIR)$(charonconfdir)/$$name" || $(INSTALL) -m 644 "$$dir$$f" "$(DESTDIR)$(charonconfdir)/$$name.sample" || true; \
++ test -f "$(DESTDIR)$(charonconfdir)/$$name" || $(INSTALL) -m 644 "$$dir$$f" "$(DESTDIR)$(charonconfdir)/$${name}.sample" || true; \
done
# Tell versions [3.59,3.63) of GNU make to not export all variables.