aboutsummaryrefslogtreecommitdiff
path: root/security/stunnel/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-01-09 09:54:54 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-01-09 09:54:54 +0000
commite9d65ec173277b6810eeb27a6cbb9dc55a6d340c (patch)
tree51258fc5ce73142fe606afc6bad5bd41e01252e2 /security/stunnel/Makefile
parente0c1a40d84736ded38dcc4a9ebc742844c5402e3 (diff)
downloadports-e9d65ec173277b6810eeb27a6cbb9dc55a6d340c.tar.gz
ports-e9d65ec173277b6810eeb27a6cbb9dc55a6d340c.zip
Notes
Diffstat (limited to 'security/stunnel/Makefile')
-rw-r--r--security/stunnel/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 4ebe76f177e2..edd62721ca78 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stunnel
-PORTVERSION= 4.00
+PORTVERSION= 4.03
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/ \
@@ -19,9 +19,10 @@ USE_OPENSSL= YES
USE_REINPLACE= YES
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/tmp --with-pem-dir=${PEM_DIR}
+CONFIGURE_ARGS= --localstatedir=/var/tmp --with-pem-dir=${PEM_DIR} \
+ --enable-static
-MAN8= stunnel.8
+MAN8= stunnel.8 stunnel.pl.8
PEM_DIR?= ${PREFIX}/etc
@@ -59,7 +60,7 @@ cert:
@${ECHO} "The new certificate will be saved into ${PREFIX}/etc/stunnel.pem"
@${ECHO} "**************************************************************************"
@${ECHO} ""
- @(cd ${WRKSRC}; make cert)
- ${INSTALL} -m 600 ${WRKSRC}/stunnel.pem ${PEM_DIR}/
+ @(cd ${WRKSRC}/tools/; make stunnel.pem)
+ ${INSTALL} -m 600 ${WRKSRC}/tools/stunnel.pem ${PEM_DIR}/
.include <bsd.port.mk>