aboutsummaryrefslogtreecommitdiff
path: root/security/stunnel/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-07-13 08:41:58 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-07-13 08:41:58 +0000
commit6d01095715a5602dc0c5e6c2a70ca8b2ee0a0f76 (patch)
tree687421f0bf5cbbff3972b16968d5cf46b5fe0fd3 /security/stunnel/Makefile
parente8f0403b6dc5c63d3aa0bb01a9c6dacaf16abfbd (diff)
downloadports-6d01095715a5602dc0c5e6c2a70ca8b2ee0a0f76.tar.gz
ports-6d01095715a5602dc0c5e6c2a70ca8b2ee0a0f76.zip
Notes
Diffstat (limited to 'security/stunnel/Makefile')
-rw-r--r--security/stunnel/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 8ea82f9f2be0..e452b5b87851 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= stunnel
-PORTVERSION= 4.10
-PORTREVISION= 3
+PORTVERSION= 4.11
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \
@@ -47,13 +46,17 @@ CONFIGURE_ARGS+= --enable-ipv6
BROKEN= 'The WITH_UCONTEXT, WITH_FORK and WITH_PTHREAD options are mutually exclusive - please specify at most one of them, the default is WITH_PTHREAD'
.endif
-CFLAGS+=-DFORCE_THREADING_MODEL
.if defined(WITH_UCONTEXT)
-CFLAGS+=-DFORCE_UCONTEXT
+.if ${OSVERSION} < 500112
+BROKEN= 'The ucontext model is only supported on FreeBSD 5.x and 6.x'
+.endif
+CONFIGURE_ARGS+=--with-threads=ucontext
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
.elif defined(WITH_FORK)
-CFLAGS+=-DFORCE_FORK
+CONFIGURE_ARGS+=--with-threads=fork
.else
-CFLAGS+=-DFORCE_PTHREAD
+CONFIGURE_ARGS+=--with-threads=pthread
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
.endif
post-patch: