aboutsummaryrefslogtreecommitdiff
path: root/security/stunnel
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-10-21 11:36:26 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-10-21 11:36:26 +0000
commit10806a3198d8aac43153fb35ab287e01769c9161 (patch)
treed20a85cfd6432d462ef7327147c75b7e4b788056 /security/stunnel
parentabc08b04e811cebddf17889009bea537b3abbc74 (diff)
Notes
Diffstat (limited to 'security/stunnel')
-rw-r--r--security/stunnel/Makefile28
1 files changed, 20 insertions, 8 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index c2647c77cc83..3d7d8f01bfb2 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -7,17 +7,22 @@
PORTNAME= stunnel
PORTVERSION= 4.34
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
- ftp://stunnel.mirt.net/stunnel/ \
- ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \
- ftp://opensores.thebunker.net/pub/mirrors/stunnel/download/stunnel/src/
+ http://mirrors.zerg.biz/stunnel/%SUBDIR%/ \
+ ftp://stunnel.mirt.net/stunnel/%SUBDIR%/ \
+ ftp://ftp.nluug.nl/pub/networking/stunnel/%SUBDIR%/ \
+ http://ftp.nluug.nl/pub/networking/stunnel/%SUBDIR%/ \
+ ftp://ftp.surfnet.nl/pub/networking/stunnel/%SUBDIR%/ \
+ http://ftp.surfnet.nl/pub/networking/stunnel/%SUBDIR%/ \
+ http://mirrors.zerg.biz/stunnel/%SUBDIR%/
+MASTER_SITE_SUBDIR= . obsolete/4.x
MAINTAINER= roam@FreeBSD.org
COMMENT= SSL encryption wrapper for standard network daemons
USE_AUTOTOOLS= libtool:22
-USE_OPENSSL= YES
USE_RC_SUBR= stunnel
GNU_CONFIGURE= yes
@@ -32,14 +37,21 @@ OPTIONS= FORK "use the fork(3) threading model" off \
PTHREAD "use the pthread(3) threading model (default)" on \
UCONTEXT "use the ucontext(3) threading model" off \
IPV6 "enable IPv6 support" off \
- LIBWRAP "use TCP wrappers" on
+ LIBWRAP "use TCP wrappers" on \
+ SSL_PORT "use OpenSSL from the Ports Collection" on
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
+.if defined(WITH_SSL_PORT)
+USE_OPENSSL= YES
+WITH_OPENSSL_PORT= yes
+CONFIGURE_ARGS+= --with-ssl="${OPENSSLBASE}"
+.else
+CONFIGURE_ARGS+= --with-ssl=/usr
.endif
+.include <bsd.port.pre.mk>
+
.if defined(WITH_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.else