aboutsummaryrefslogtreecommitdiff
path: root/security/stunnel
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-07-13 08:41:58 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-07-13 08:41:58 +0000
commit6d01095715a5602dc0c5e6c2a70ca8b2ee0a0f76 (patch)
tree687421f0bf5cbbff3972b16968d5cf46b5fe0fd3 /security/stunnel
parente8f0403b6dc5c63d3aa0bb01a9c6dacaf16abfbd (diff)
downloadports-6d01095715a5602dc0c5e6c2a70ca8b2ee0a0f76.tar.gz
ports-6d01095715a5602dc0c5e6c2a70ca8b2ee0a0f76.zip
Notes
Diffstat (limited to 'security/stunnel')
-rw-r--r--security/stunnel/Makefile15
-rw-r--r--security/stunnel/distinfo4
-rw-r--r--security/stunnel/files/patch-src::common.h50
-rw-r--r--security/stunnel/files/patch-src::sthreads.c12
4 files changed, 11 insertions, 70 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 8ea82f9f2be0..e452b5b87851 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= stunnel
-PORTVERSION= 4.10
-PORTREVISION= 3
+PORTVERSION= 4.11
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \
@@ -47,13 +46,17 @@ CONFIGURE_ARGS+= --enable-ipv6
BROKEN= 'The WITH_UCONTEXT, WITH_FORK and WITH_PTHREAD options are mutually exclusive - please specify at most one of them, the default is WITH_PTHREAD'
.endif
-CFLAGS+=-DFORCE_THREADING_MODEL
.if defined(WITH_UCONTEXT)
-CFLAGS+=-DFORCE_UCONTEXT
+.if ${OSVERSION} < 500112
+BROKEN= 'The ucontext model is only supported on FreeBSD 5.x and 6.x'
+.endif
+CONFIGURE_ARGS+=--with-threads=ucontext
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
.elif defined(WITH_FORK)
-CFLAGS+=-DFORCE_FORK
+CONFIGURE_ARGS+=--with-threads=fork
.else
-CFLAGS+=-DFORCE_PTHREAD
+CONFIGURE_ARGS+=--with-threads=pthread
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
.endif
post-patch:
diff --git a/security/stunnel/distinfo b/security/stunnel/distinfo
index b465790a2894..11ee1392adcc 100644
--- a/security/stunnel/distinfo
+++ b/security/stunnel/distinfo
@@ -1,2 +1,2 @@
-MD5 (stunnel-4.10.tar.gz) = 9de7a62a44083114779ca4e109d70776
-SIZE (stunnel-4.10.tar.gz) = 487066
+MD5 (stunnel-4.11.tar.gz) = 253c50435d4d81cba6f19ca34266e6dc
+SIZE (stunnel-4.11.tar.gz) = 484559
diff --git a/security/stunnel/files/patch-src::common.h b/security/stunnel/files/patch-src::common.h
deleted file mode 100644
index c19cd216ad5d..000000000000
--- a/security/stunnel/files/patch-src::common.h
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/common.h.orig Sat Apr 23 13:40:10 2005
-+++ src/common.h Tue Jun 14 08:27:11 2005
-@@ -38,17 +38,44 @@
- #endif
-
- /* threads model */
-+#if defined(FORCE_THREADING_MODEL)
-+
-+#undef USE_UCONTEXT
-+#undef USE_PTHREAD
-+#undef USE_FORK
-+
-+#ifdef FORCE_UCONTEXT
-+#define USE_UCONTEXT
-+#else
-+#ifdef FORCE_PTHREAD
-+#define USE_PTHREAD
-+#else
-+#define USE_FORK
-+#endif /* FORCE_PTHREAD */
-+#endif /* FORCE_UCONTEXT */
-+
-+#else /* FORCE_THREADING_MODEL */
-+
- #if HAVE_UCONTEXT_H && HAVE_GETCONTEXT && HAVE_POLL
- #define USE_UCONTEXT
--#include <ucontext.h>
- #elif HAVE_PTHREAD_H && HAVE_LIBPTHREAD
- #define USE_PTHREAD
-+#else
-+#define USE_FORK
-+#endif
-+
-+#endif /* FORCE_THREADING_MODEL */
-+
-+#ifdef USE_UCONTEXT
-+#include <sys/types.h>
-+#include <ucontext.h>
-+#endif
-+
-+#ifdef USE_PTHREAD
- #include <pthread.h>
- #define THREADS
- #define _REENTRANT
- #define _THREAD_SAFE
--#else
--#define USE_FORK
- #endif
-
- /* TCP wrapper */
diff --git a/security/stunnel/files/patch-src::sthreads.c b/security/stunnel/files/patch-src::sthreads.c
deleted file mode 100644
index d1dfd346efb0..000000000000
--- a/security/stunnel/files/patch-src::sthreads.c
+++ /dev/null
@@ -1,12 +0,0 @@
-*** src/sthreads.c.old Mon Jun 13 21:34:53 2005
---- src/sthreads.c Mon Jun 13 22:15:01 2005
-***************
-*** 63,68 ****
---- 63,69 ----
-
- static void ctx_cleanup_func(void) { /* cleanup the active thread */
- s_log(LOG_DEBUG, "Context %ld closed", ready_head->id);
-+ makecontext(&ctx_cleanup, ctx_cleanup_func, 0);
- s_poll_wait(NULL, 0); /* wait on poll() */
- }
-