aboutsummaryrefslogtreecommitdiff
path: root/security/stunnel
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-01-03 09:54:20 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-01-03 09:54:20 +0000
commit3decfd3c3c2b76dc4a55118cca3e93ef8aafa779 (patch)
treed91067a69b60f18f74f7b59212a8f8a0483c6bee /security/stunnel
parentef94f48a8bdd4872c692557c4716f81c67951fec (diff)
downloadports-3decfd3c3c2b76dc4a55118cca3e93ef8aafa779.tar.gz
ports-3decfd3c3c2b76dc4a55118cca3e93ef8aafa779.zip
Notes
Diffstat (limited to 'security/stunnel')
-rw-r--r--security/stunnel/Makefile3
-rw-r--r--security/stunnel/distinfo4
-rw-r--r--security/stunnel/files/patch-src::network.c36
3 files changed, 9 insertions, 34 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index bf61841b913c..7330326347b9 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= stunnel
-PORTVERSION= 4.06
-PORTREVISION= 2
+PORTVERSION= 4.07
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \
diff --git a/security/stunnel/distinfo b/security/stunnel/distinfo
index 19053f47a817..50c938857b2d 100644
--- a/security/stunnel/distinfo
+++ b/security/stunnel/distinfo
@@ -1,2 +1,2 @@
-MD5 (stunnel-4.06.tar.gz) = bac37fe3ecb61a0481188694e0823220
-SIZE (stunnel-4.06.tar.gz) = 484200
+MD5 (stunnel-4.07.tar.gz) = 7d53af550a1c2e01e146b936e58b8860
+SIZE (stunnel-4.07.tar.gz) = 486230
diff --git a/security/stunnel/files/patch-src::network.c b/security/stunnel/files/patch-src::network.c
index c95c293ad6a2..dd41ae7f3d49 100644
--- a/security/stunnel/files/patch-src::network.c
+++ b/security/stunnel/files/patch-src::network.c
@@ -1,40 +1,16 @@
---- src/network.c.orig Thu Oct 14 18:03:49 2004
-+++ src/network.c Thu Dec 30 16:12:16 2004
-@@ -125,7 +125,7 @@
- int retval;
+--- src/network.c.orig Mon Jan 3 09:16:45 2005
++++ src/network.c Mon Jan 3 09:17:49 2005
+@@ -488,10 +488,13 @@
- do { /* skip "Interrupted system call" errors */
-- retval=poll(fds->ufds, fds->nfds, 1000*timeout);
-+ retval=poll(fds->ufds, fds->nfds, timeout < 0? INFTIM: 1000*timeout);
- /* no timeout -> main loop */
- if(timeout<0 && retval>0 && s_poll_canread(fds, signal_pipe[0]))
- signal_pipe_empty();
-@@ -416,8 +416,12 @@
- return "Temporary failure in name resolution (EAI_AGAIN)";
- case EAI_FAIL:
- return "Non-recoverable failure in name resolution (EAI_FAIL)";
-+#ifdef EAI_NODATA
-+#if EAI_NODATA != EAI_NONAME
- case EAI_NODATA:
- return "No address associated with nodename (EAI_NODATA)";
-+#endif
-+#endif
- case EAI_FAMILY:
- return "ai_family not supported (EAI_FAMILY)";
- case EAI_SOCKTYPE:
-@@ -561,11 +565,14 @@
-
- /* getnameinfo() version */
char *s_ntop(char *text, SOCKADDR_UNION *addr) {
-- char host[20], port[6];
-+ char host[IPLEN], port[6];
+ char host[IPLEN-6], port[6];
+ int err;
- if(getnameinfo(&addr->sa, addr_len(*addr),
-- host, 20, port, 6, NI_NUMERICHOST|NI_NUMERICSERV)) {
+- host, IPLEN-6, port, 6, NI_NUMERICHOST|NI_NUMERICSERV)) {
- sockerror("getnameinfo");
+ err = getnameinfo(&addr->sa, addr_len(*addr),
-+ host, IPLEN, port, 6, NI_NUMERICHOST|NI_NUMERICSERV);
++ host, IPLEN-6, port, 6, NI_NUMERICHOST|NI_NUMERICSERV);
+ if (err) {
+ s_log(LOG_ERR, "Error resolving the specified address: %s",
+ s_gai_strerror(err));